Opened 6 years ago

Closed 6 years ago

#5241 closed bug (invalid)

documentation in ghc 7.0.3 sources fails to build on OpenSuSE 11.4

Reported by: gatoatigrado Owned by:
Priority: normal Milestone:
Component: Compiler Version: 7.0.3
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

When building the ghc 7.0.3 source distribution on OpenSuSE 11.4, LaTeX errors when building the documentation. Here is some relevant information:

I don't really need the documentation -- optimally, it could prompt the user whether the documentaiton is necessary, and continue building if not.

Change History (8)

comment:1 Changed 6 years ago by daniel.is.fischer

I think the cause is dblatex (at least, that caused a build error trying to build the pdf docs on openSuSE 11.3). I think 11.4 also ships with dblatex-0.27, which was the version crashing here. As far as I know, dblatex >= 0.29 works. Setting

BUILD_DOCBOOK_PS   = NO
BUILD_DOCBOOK_PDF  = NO

in mk/build.mk should also solve it (html documentation builds without errors).

comment:2 Changed 6 years ago by igloo

What do dblatex --version and dblatex --help say for you?

And what is the description of the OpenSuSE package containing dblatex?

comment:3 Changed 6 years ago by igloo

Status: newinfoneeded

comment:4 Changed 6 years ago by gatoatigrado

Unfortunately, it doesn't seem to just be dblatex. The version was 0.2.7, but upgrading to 0.3 via repository [ here ] didn't seem to help.

It seems to get a little farther building though,

comment:5 Changed 6 years ago by daniel.is.fischer

Hmm, I just installed dblatex-0.3 from the 11.3 repo there, ps and pdf docs built fine.

Ian, you had to wrestle a bit to get it to build on OS X, maybe it's an issue of !TeXLive 2010 vs. 2009?

comment:6 Changed 6 years ago by rel-eng

Exactly the same problem was discussed at http://web.archiveorange.com/archive/v/2B0uX7FySQYBDjsOjrT6

comment:7 Changed 6 years ago by daniel.is.fischer

Okay, tried on openSuSE 11.4 (64bit) with dblatex-0.3, failed with

Writing docs/users_guide/users_guide/index.html for book(users-guide)
cp mk/fptools.css docs/users_guide/users_guide/
cp docs/users_guide/prof_scc.png docs/users_guide/users_guide/prof_scc.png
"/usr/bin/dblatex"  docs/users_guide/users_guide.xml --ps -o docs/users_guide/users_guide.ps
Build the book set list...
Build the listings...
XSLT stylesheets DocBook - LaTeX 2e (0.3)
===================================================
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
Pixel unit not handled (replaced by pt)
Pixel unit not handled (replaced by pt)
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
subscript: default template used in programlisting or screen
superscript: default template used in programlisting or screen
superscript: default template used in programlisting or screen
superscript: default template used in programlisting or screen
superscript: default template used in programlisting or screen
superscript: default template used in programlisting or screen
superscript: default template used in programlisting or screen
superscript: default template used in programlisting or screen
superscript: default template used in programlisting or screen
superscript: default template used in programlisting or screen
superscript: default template used in programlisting or screen
Found eps for 'prof_scc'
Build users_guide.ps
This is pdfTeX, Version 3.1415926-1.40.11 (TeX Live 2010)
 restricted \write18 enabled.
entering extended mode
latex failed
users_guide.tex:1702: Undefined control sequence \Documents.
users_guide.tex:1702: leading text: }
users_guide.tex:1702: Undefined control sequence \user.
users_guide.tex:1702: leading text: }
users_guide.tex:4064: Undefined control sequence \Person.
users_guide.tex:4064: leading text:       or \nolinkurl{Data\Person.hs}
users_guide.tex:6256: Undefined control sequence \Documents.
users_guide.tex:6256: leading text: ...ts~And~Settings\user\ghc\package.conf.d}
users_guide.tex:6256: Undefined control sequence \user.
users_guide.tex:6256: leading text: ...ts~And~Settings\user\ghc\package.conf.d}
users_guide.tex:6256: Undefined control sequence \ghc.
users_guide.tex:6256: leading text: ...ts~And~Settings\user\ghc\package.conf.d}
users_guide.tex:6256: Undefined control sequence \package.
users_guide.tex:6256: leading text: ...ts~And~Settings\user\ghc\package.conf.d}
users_guide.tex:24345: Undefined control sequence \cygwin.
users_guide.tex:24345: leading text: \nolinkurl{/} is \nolinkurl{C:\cygwin\ }
users_guide.tex:24351: Undefined control sequence \cygwin.
users_guide.tex:24351: leading text: system (probably \nolinkurl{C:\cygwin\bin}
users_guide.tex:24351: Undefined control sequence \bin.
users_guide.tex:24351: leading text: system (probably \nolinkurl{C:\cygwin\bin}
users_guide.tex:24351: Undefined control sequence \cygwin.
users_guide.tex:24351: leading text: ...} and \nolinkurl{C:\cygwin\usr\include}
users_guide.tex:24351: Undefined control sequence \usr.
users_guide.tex:24351: leading text: ...} and \nolinkurl{C:\cygwin\usr\include}
users_guide.tex:24351: Incomplete \iffalse; all text was ignored after line 24351.
users_guide.tex: Emergency stop.
Unexpected error occured
[ -f docs/users_guide/users_guide.ps ]
make[1]: *** [docs/users_guide/users_guide.ps] Fehler 1
make: *** [all] Fehler 2

It works on 11.3 with TeXLive 2009, fails on 11.4 with TeXLive 2010, but works with the changes in Ian's post linked above, with a modification since openSuSE has a different structure for TeXLive,

replace texlive.version 2010 with 2009 in /usr/share/dblatex/xsl/param.xsl
set openout_any = r in /etc/texmf/web2c/texmf.cnf

Since it is so brittle, perhaps the ps and pdf docs should by default not be built?

comment:8 Changed 6 years ago by igloo

Resolution: invalid
Status: infoneededclosed

As far as I can see the problem is broken dblatex installations, so I don't think this is a GHC bug.

Note: See TracTickets for help on using tickets.