Opened 3 years ago

Closed 3 years ago

#5036 closed bug (worksforme)

ghc bug: urk! lookup local fingerprint

Reported by: guest Owned by:
Priority: high Milestone: 7.2.1
Component: Compiler Version: 7.1
Keywords: Cc:
Operating System: Linux Architecture: x86
Type of failure: Compile-time crash Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description (last modified by igloo)

┌─(~/.cabal/packages/hackage.haskell.org/graphalyze/Graphalyze)───────────────────────────────────────────────────────────────────────────────────(pts/16@backup)─┐
cabal clean
cleaning...
┌─(~/.cabal/packages/hackage.haskell.org/graphalyze/Graphalyze)───────────────────────────────────────────────────────────────────────────────────(pts/16@backup)─┐
cabal install                                         
Resolving dependencies...
Configuring Graphalyze-0.11.0.0...
Preprocessing library Graphalyze-0.11.0.0...
Building Graphalyze-0.11.0.0...
[ 1 of 12] Compiling Paths_Graphalyze ( dist/build/autogen/Paths_Graphalyze.hs, dist/build/Paths_Graphalyze.o )

Implicit import declaration:
    Warning: In the use of `catch'
             (imported from Prelude, but defined in System.IO.Error):
             Deprecated: "Please use the new exceptions variant, Control.Exception.catch"
[ 2 of 12] Compiling Data.Graph.Analysis.Internal ( Data/Graph/Analysis/Internal.hs, dist/build/Data/Graph/Analysis/Internal.o )
[ 3 of 12] Compiling Data.Graph.Analysis.Reporting ( Data/Graph/Analysis/Reporting.hs, dist/build/Data/Graph/Analysis/Reporting.o )
[ 4 of 12] Compiling Data.Graph.Analysis.Reporting.Pandoc ( Data/Graph/Analysis/Reporting/Pandoc.hs, dist/build/Data/Graph/Analysis/Reporting/Pandoc.o )
[ 5 of 12] Compiling Data.Graph.Analysis.Types ( Data/Graph/Analysis/Types.hs, dist/build/Data/Graph/Analysis/Types.o )
[ 6 of 12] Compiling Data.Graph.Analysis.Utils ( Data/Graph/Analysis/Utils.hs, dist/build/Data/Graph/Analysis/Utils.o )
[ 7 of 12] Compiling Data.Graph.Analysis.Visualisation ( Data/Graph/Analysis/Visualisation.hs, dist/build/Data/Graph/Analysis/Visualisation.o )
[ 8 of 12] Compiling Data.Graph.Analysis.Algorithms.Common ( Data/Graph/Analysis/Algorithms/Common.hs, dist/build/Data/Graph/Analysis/Algorithms/Common.o )

Data/Graph/Analysis/Algorithms/Common.hs:40:1:
    Warning: The import of `Data.Graph.Inductive.Query.DFS' is redundant
               except perhaps to import instances from `Data.Graph.Inductive.Query.DFS'
             To import instances alone, use: import Data.Graph.Inductive.Query.DFS()
[ 9 of 12] Compiling Data.Graph.Analysis.Algorithms.Directed ( Data/Graph/Analysis/Algorithms/Directed.hs, dist/build/Data/Graph/Analysis/Algorithms/Directed.o )
ghc: panic! (the 'impossible' happened)
  (GHC version 7.1.20110209 for i386-unknown-linux):
	urk! lookup local fingerprint
    Graphalyze-0.11.0.0:Data.Graph.Analysis.Algorithms.Directed.$slookup1{v ruPI}

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

cabal: Error: some packages failed to install:
Graphalyze-0.11.0.0 failed during the building phase. The exception was:
ExitFailure 1

Change History (4)

comment:1 Changed 3 years ago by igloo

  • Description modified (diff)

comment:2 Changed 3 years ago by simonpj

  • Milestone set to 7.2.1

Looks bad. We should clarify if this really is a bug, for 7.2

comment:3 Changed 3 years ago by igloo

  • Priority changed from normal to high

comment:4 Changed 3 years ago by igloo

  • Resolution set to worksforme
  • Status changed from new to closed

I've just built HEAD (7.1.20110325) on x86/Linux, and after various small build fixes for this package and its dependencies, I can't reproduce this.

If you are able to reproduce it on a clean GHC installation, can you please reopen and give full reproduction instructions?

Thanks!

Note: See TracTickets for help on using tickets.