Opened 3 years ago

Closed 2 years ago

#5018 closed bug (fixed)

GTK Crash occuring only with -fllvm

Reported by: tener Owned by: dterei
Priority: normal Milestone: 7.4.1
Component: Compiler (LLVM) Version: 7.0.2
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Runtime crash Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description (last modified by igloo)

I have moderately complex program written for sound synthesis course.

The largest part comprises of GUI written in GTK, the sound part is fairly small.

When compiling with -fllvm -O2 the program segfaults immediately after launch in IA__FcPatternBuild () from /usr/lib/libfontconfig.so.1. Turing off optimizations or linking with native code gen doesn't trigger the bug.

I also tried small, test GTK program but it also doesn't trigger this behaviour.

Hence I attach the program verbatim in case someone might be able to reproduce the bug and pin it down.

Obviously the bug might not be in LLVM codegen but it only happens to trigger it, so I set the Component to Compiler at whole.

Attachments (2)

zad4.hs (11.2 KB) - added by tener 3 years ago.
program triggering the bug
trace.2.txt (5.2 KB) - added by tener 3 years ago.
stack trace

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by tener

program triggering the bug

comment:1 Changed 3 years ago by tener

Forgot to mention: I'm running up to date Arch Linux distro.

Changed 3 years ago by tener

stack trace

comment:2 Changed 3 years ago by igloo

  • Description modified (diff)

comment:3 Changed 3 years ago by igloo

  • Component changed from Compiler to Compiler (LLVM)
  • Milestone set to 7.4.1
  • Owner set to davidterei@…

Thanks for the report.

If you are able to make a self-contained testcase (i.e. make it as small as possible and inline the GTK FFI calls etc into the testcase) then that would make it easier for someone to look into.

As it's only happened with LLVM, I'll assume it's LLVM-only for now.

comment:4 Changed 3 years ago by dterei

  • Owner changed from davidterei@… to dterei

comment:5 Changed 2 years ago by dterei

tener: Can you provide version information please? Which version of GHC is this? Which version of LLVM? Which Linux distro and version? Which gtk haskell package? Also if you could try reproducing with the latest version of GHC, that would be awesome!

comment:6 Changed 2 years ago by dterei

OK I can confirm. Looks like this might be a tricky bug to fix, not sure when I'll get the time.

comment:7 Changed 2 years ago by dterei

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in HEAD. I believe this was fixed when I fixed 4211.

Note: See TracTickets for help on using tickets.