Opened 3 years ago

Closed 3 years ago

#4885 closed bug (fixed)

freeGroup: block size is zero

Reported by: zukerman Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.12.3
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Runtime crash Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I'm starting on a program to accept incoming UDP packets and dump them to files. The simple example I'm attaching below dies after a few minutes under load with either a segmentation fault or this:

internal error: freeGroup: block size is zero

(GHC version 6.12.3 for x86_64_unknown_linux)

Attachments (2)

udpcount.hs (2.6 KB) - added by zukerman 3 years ago.
udpsend.hs (824 bytes) - added by zukerman 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by zukerman

Changed 3 years ago by zukerman

comment:1 Changed 3 years ago by zukerman

BTW, I'm running it like this:

./udpcount 10000 +RTS -K256M -N2

comment:2 Changed 3 years ago by zukerman

  • Architecture changed from Unknown/Multiple to x86_64 (amd64)
  • Operating System changed from Unknown/Multiple to Linux
  • Type of failure changed from None/Unknown to Runtime crash

comment:3 Changed 3 years ago by igloo

  • Resolution set to fixed
  • Status changed from new to closed

I can't reproduce this with 7.0.1, compiling with

ghc --make udpcount.hs -O -rtsopts -threaded
ghc --make udpsend.hs -O

and running

./udpcount 10000 +RTS -K256M -N2 

along with a couple of instances of

./udpsend < /boot/vmlinuz-2.6.32-5-amd64
Note: See TracTickets for help on using tickets.