Opened 3 years ago

Closed 3 years ago

#4878 closed bug (fixed)

Bindist build tools assume libffi.so.5 availability

Reported by: vmj Owned by:
Priority: normal Milestone:
Component: Build System Version: 7.0.1
Keywords: Cc:
Operating System: Linux Architecture: x86
Type of failure: Installing GHC failed Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

To be able to install the generic i386 Linux binary distribution, I had to do this little trick before doing the 'configure && make install':

cp libffi/dist-install/build/libHSffi-ghc7.0.1.so libffi/libffi.so.5

export LD_LIBRARY_PATH=$(pwd)/libffi/

This was because my up-to-date Slackware 13.1 ships with libffi.so.4 and some of the installation tools in above mentioned package have been linked against libffi.so.5.

Change History (1)

comment:1 Changed 3 years ago by igloo

  • Resolution set to fixed
  • Status changed from new to closed

This is fixed (in HEAD and 7.0 branch) now that we build all binaries in the bindists with the in-tree compiler.

Note: See TracTickets for help on using tickets.