Opened 8 years ago

Closed 8 years ago

Last modified 44 years ago

#483 closed bug (Fixed)

nativeGen/MachRegs.lhs:1016: parse error

Reported by: jgoerzen Owned by: nobody
Priority: normal Milestone:
Component: Compiler Version: None
Keywords: Cc:
Operating System: Architecture:
Type of failure: Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I am attempting to build GHC 6.4.1 on AIX 5.1L using
GHC 6.2.1 as the host compiler.

Everything proceeds fine until the crash here.

I believe that the problem is that no content for the
callClobberedRegs defined for AIX.  In particular,
powerpc_TARGET_ARCH will be defined, but there is no
clause in that file for PowerPC.

I will attach a build log.

Attachments (1)

typescript.2 (197.6 KB) - added by jgoerzen 8 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 8 years ago by jgoerzen

Logged In: YES 
user_id=491567

Forgot to add: using GCC 4.0.3.

Changed 8 years ago by jgoerzen

comment:2 Changed 8 years ago by jgoerzen

  • Status changed from assigned to closed

comment:3 Changed 8 years ago by jgoerzen

Logged In: YES 
user_id=491567

a further comment: perhaps this is a configure error --
nativeGen still isn't available on AIX, is it?

I just ran ./configure --prefix=/usr/local to start this.

comment:4 Changed 8 years ago by simonmar

  • Status changed from assigned to closed
Logged In: YES 
user_id=48280

Fixed to omit building the NCG on AIX by default.
Note: See TracTickets for help on using tickets.