Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4475 closed bug (wontfix)

unreliable ghc on sparc

Reported by: maeder Owned by:
Priority: normal Milestone: 7.2.1
Component: Compiler Version: 7.1
Keywords: Cc:
Operating System: Solaris Architecture: sparc
Type of failure: Compile-time crash Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I was able to create and successfully use ghc-7 RC2
http://www.informatik.uni-bremen.de/agbkb/forschung/formal_methods/CoFI/hets/solaris/ghcs/ghc-7.0.0.20101028-sparc-sun-solaris2.tar.bz2

However, compilation does not work reliable so that it needs to be repeated some times. Also "cabal install" sometimes fails, because a .a lib was not created.

I've observed the same problem with ghc-6.12.3 #3812 and I hope it is not a hardware problem.

Can someone else reproduce these problems?

Change History (6)

comment:1 Changed 3 years ago by maeder

I do no longer think that it is a hardware problem, because ghc-6.10.4 still runs reliable and ghc-6.12.3 also runs unreliable on another hardware.

The other machine only has gcc-3.4.4 and I was not able to use this gcc with ghc-7.0.0.20101028, since my binary-dist somehow uses the newer gcc option "-fno-stack-protector" (unfortunately not via extra-gcc-opts).

comment:2 Changed 3 years ago by igloo

I assume this is a registerised build? If so, I'm afraid it's not a tier 1 platform, so we don't actively fix this sort of issue ourselves, but rely on community members to debug and fix such platform-specific issues.

If someone wants to look into this and gets stuck, we'll do our best to unstick you, though.

comment:3 Changed 3 years ago by igloo

  • Milestone set to 7.0.2

comment:4 Changed 3 years ago by igloo

  • Milestone changed from 7.0.2 to 7.2.1

comment:5 Changed 3 years ago by igloo

  • Resolution set to wontfix
  • Status changed from new to closed

Not a tier 1 platform, so closing.

comment:6 Changed 3 years ago by maeder

I think this ticket is even fixed by using gcc-4.3.6 (see #5013) as I have a reliable ghc-7.0.4 now. (Due to #5407 I've no ghc-7.2.1, though)

Note: See TracTickets for help on using tickets.