Opened 5 years ago

Closed 5 years ago

#4388 closed bug (duplicate)

Unexpected failures, too much allocation

Reported by: daniel.is.fischer Owned by:
Priority: high Milestone: 7.4.1
Component: Test Suite Version: 7.1
Keywords: test suite, allocation Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

I have two failures in the test suite due to too much allocation:

=====> T1969(normal) 2224 of 2601 [0, 1, 0]
cd ./perf/compiler && '/home/dafis/Haskell/Hacking/newghc/inplace/bin/ghc-stage2' -fforce-recomp -dcore-lint -dcmm-lint -dno-debug-output -no-user-package-conf -rtsopts -optl-lz -c T1969.hs   +RTS -V0 -tT1969.comp.stats --machine-readable -RTS  >T1969.comp.stderr 2>&1
bytes allocated 288515060 is more than maximum allowed 270000000
*** unexpected failure for T1969(normal)
=====> T3294(normal) 2225 of 2601 [0, 2, 0]
cd ./perf/compiler && '/home/dafis/Haskell/Hacking/newghc/inplace/bin/ghc-stage2' -fforce-recomp -dcore-lint -dcmm-lint -dno-debug-output -no-user-package-conf -rtsopts -optl-lz -c T3294.hs   +RTS -V0 -tT3294.comp.stats --machine-readable -RTS  >T3294.comp.stderr 2>&1
bytes allocated 969743900 is more than maximum allowed 850000000
*** unexpected failure for T3294(normal)

Change History (7)

comment:1 Changed 5 years ago by simonpj

Thanks. I believe that these two failures are due to the 'containers' patch. This patch doesn't exist on the 7.0 branch. For HEAD our plan is to await Milan's upcoming fixes.

Simon

comment:2 Changed 5 years ago by igloo

  • Milestone set to 7.2.1
  • Priority changed from normal to high

comment:3 Changed 5 years ago by daniel.is.fischer

My latest HEAD just made it for T1969:

/home/dafis/Haskell/Hacking/ratstuff/bindisttest/install dir/lib/ghc-7.1.20101015/ghc
 -B/home/dafis/Haskell/Hacking/ratstuff/bindisttest/install dir/lib/ghc-7.1.20101015
 -pgmc /usr/bin/gcc -pgma /usr/bin/gcc -pgml /usr/bin/gcc -pgmP /usr/bin/gcc -E
 -undef -traditional -fforce-recomp -dcore-lint -dcmm-lint -dno-debug-output
 -no-user-package-conf -rtsopts -c T1969.hs +RTS -V0 -tT1969.comp.stats --machine-readable
 [("bytes allocated", "269780444")
 ,("num_GCs", "386")
 ,("average_bytes_used", "3472012")
 ,("max_bytes_used", "5944572")
 ,("num_byte_usage_samples", "8")
 ,("peak_megabytes_allocated", "19")
 ,("init_cpu_seconds", "0.01")
 ,("init_wall_seconds", "0.00")
 ,("mutator_cpu_seconds", "1.31")
 ,("mutator_wall_seconds", "1.62")
 ,("GC_cpu_seconds", "0.78")
 ,("GC_wall_seconds", "0.81")
 ]

close shave, though.

T3294 got better too:

bytes allocated 912566272 is more than maximum allowed 850000000

comment:4 Changed 5 years ago by daniel.is.fischer

T1969 failed again with a perf build, though, the above pass was with a validate build.

comment:5 Changed 5 years ago by daniel.is.fischer

Ohhh, but that was sooo close: bytes allocated 270384028 is more than maximum allowed 270000000

T3294 also gets better: bytes allocated 908713816 is more than maximum allowed 850000000

comment:6 Changed 5 years ago by daniel.is.fischer

Regression for T1969:

=====> T1969(normal) 2244 of 2622 [0, 2, 0]
cd ./perf/compiler && '/home/dafis/Haskell/Hacking/newghc/bindisttest/install dir/bin/ghc' -fforce-recomp -dcore-lint -dcmm-lint -dno-debug-output -no-user-package-conf -rtsopts -optl-lz -c T1969.hs   +RTS -V0 -tT1969.comp.stats --machine-readable -RTS  >T1969.comp.stderr 2>&1
bytes allocated 528346224 is more than maximum allowed 270000000
*** unexpected failure for T1969(normal)

Not much difference for T3294:

=====> T3294(normal) 2245 of 2622 [0, 2, 0]
cd ./perf/compiler && '/home/dafis/Haskell/Hacking/newghc/bindisttest/install dir/bin/ghc' -fforce-recomp -dcore-lint -dcmm-lint -dno-debug-output -no-user-package-conf -rtsopts -optl-lz -c T3294.hs   +RTS -V0 -tT3294.comp.stats --machine-readable -RTS  >T3294.comp.stderr 2>&1
bytes allocated 911296288 is more than maximum allowed 850000000
*** unexpected failure for T3294(normal)

comment:7 Changed 5 years ago by igloo

  • Resolution set to duplicate
  • Status changed from new to closed

The recent regression should be fixed by

Tue Oct 26 22:15:46 BST 2010  Ian Lynagh <[email protected]>
  * Use removeDups to find top-level duplicate names
  findDupsEq is quadratic, whereas removeDups is n log n.
  Fixes T1969 regression.

I'm closing this ticket as a duplicate of #4342.

Note: See TracTickets for help on using tickets.