Opened 9 years ago

Closed 9 years ago

Last modified 44 years ago

#434 closed bug (Fixed)

panic compiling classes

Reported by: abrim Owned by: nobody
Priority: normal Milestone:
Component: Compiler Version: 6.4
Keywords: Cc:
Operating System: Architecture:
Type of failure: Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

$ ghc Bug.hs
ghc-6.4: panic! (the `impossible' happened, GHC version
6.4):
        ds_app_type Bug.Class1{tc r155} []

$ cat Bug.hs
module Bug where

class Class1 a where

class Class2 a where
  class1 :: a -> Class1


Change History (1)

comment:1 Changed 9 years ago by simonmar

  • Status changed from assigned to closed
Logged In: YES 
user_id=48280

Thanks, fixed (also a duplicate of [ ghc-Bugs-1179433 ]).
Note: See TracTickets for help on using tickets.