Opened 5 years ago

Closed 5 years ago

#4330 closed bug (fixed)

Weird runtime Crash

Reported by: nomeata Owned by:
Priority: high Milestone: 7.0.1
Component: Runtime System Version: 6.12.1
Keywords: Cc: leuschner@…
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Runtime crash Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

I’m sure you like such summaries... but I could not do any better.

In the attached tarball is some code and a test.sh that can be used to show the bug. I tried to further reduce the size of the test case, but I’m in a position where any of numerous seemingly independent changes would cause the crash to not happen, including removing an unused binding of the form "blubb <- return undefined", merging two Modules, removing unused imports or removing unused definitions.

Also disabling -O2 or -prof hides the patch.

I have attached my attempts to reduce the size of the testcase as a patch. Some code positions that can trigger or untrigger the bug are marked.

Attachments (2)

DociGateway.tar.bz2 (5.8 KB) - added by nomeata 5 years ago.
Testcase
4330-reduce-size.patch (17.9 KB) - added by nomeata 5 years ago.
Attempts to reduce the test case size

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by nomeata

Testcase

Changed 5 years ago by nomeata

Attempts to reduce the test case size

comment:1 Changed 5 years ago by dleuschner

  • Cc leuschner@… added

comment:2 Changed 5 years ago by simonmar

  • Component changed from Compiler to Runtime System
  • Milestone set to 7.0.1
  • Priority changed from normal to high

confirmed.

comment:3 Changed 5 years ago by simonmar

  • Resolution set to fixed
  • Status changed from new to closed

Doesn't seem to happen with 7.0:

Running...
Before
Reading config file `/home/simonmar/scratch/DociGateway/MobileGateway.ini'...
Evaluated1
ConfigMain: <<loop>>

So I imagine the problem was that 6.12.3 had trouble with the blackhole loop in profiling mode.

Note: See TracTickets for help on using tickets.