Opened 4 years ago

Closed 4 years ago

#4292 closed bug (fixed)

Windows installer (6.12.3) issues

Reported by: claus Owned by: igloo
Priority: high Milestone: 7.0.1
Component: None Version: 6.12.3
Keywords: Cc:
Operating System: Windows Architecture: Unknown/Multiple
Type of failure: None/Unknown Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Collecting some current issues to avoid in forthcoming installers (there does not seem to be an installer category?). I don't know when these were introduced, but I've just reinstalled ghc-6.12.3 to make sure these are due to the installer.

  1. .hs is still registered to ghc_haskell (cf. #916). I lost my existing shell command additions for that file type, but did not check whether that happened during uninstall or install.
  1. The icons directory doesn't exist, no ghc/haskell icon for .hs files
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ghc_haskell\DefaultIcon
        (Standard)    REG_SZ    C:\haskell\ghc\ghc-6.12.3\icons\hsicon.ico
    
  1. I've uninstalled, then installed GHC, but ghc-pkg list still reports remnants of previous install (after ghc-pkg recache, it still lists ghc-paths, from the local package db). Is that intended? Is it documented which parts of an installation should survive (ghci.conf: yes; filetype associations and commands should, but don't; anything else?)?
  1. ghc-pkg field * haddock-html lists the lib/* directories, not anything related to documentation (with the original installer, you need to issue this command in an empty directory, to work around #4156).
    $ ghc-pkg field * haddock-html
    haddock-html: C:\haskell\datadir\doc\ghc-paths-0.1.0.6\html
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/Win32-2.2.0.2
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/time-1.1.4
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/template-haskell-2.4.0.1
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/syb-0.1.0.2
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/random-1.0.0.2
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/process-1.0.1.3
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/pretty-1.0.1.1
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/old-time-1.0.0.5
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/old-locale-1.0.0.2
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/integer-gmp-0.2.0.1
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/hpc-0.5.0.5
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/haskell98-1.0.1.1
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/ghc-prim-0.2.0.0
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/ghc-binary-0.5.0.2
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/ghc-6.12.3
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/filepath-1.1.0.4
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/extensible-exceptions-0.1.1.1
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/dph-seq-0.4.0
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/dph-prim-seq-0.4.0
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/dph-prim-par-0.4.0
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/dph-prim-interface-0.4.0
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/dph-par-0.4.0
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/dph-base-0.4.0
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/directory-1.0.1.1
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/containers-0.3.0.0
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/Cabal-1.8.0.6
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/bytestring-0.9.1.7
    haddock-html:
    haddock-html:
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/bin-package-db-0.0.0.0
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/base-4.2.0.2
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/base-3.0.3.2
    haddock-html: C:/haskell/ghc/ghc-6.12.3\lib/array-0.3.0.1
    
  1. Documentation cross-links are thoroughly messed up (the urls seem to be missing the package identifier): eg, the Bool in Data.List refer to libraries/Data-Bool.. instead of libraries/base-4.2.0.2%5CData-Bool..
  1. Trying to cabal-install packages on top of this leads to documentation problems:
    Running Haddock for ghc-paths-0.1.0.6...
    Preprocessing library ghc-paths-0.1.0.6...
    Warning: The documentation for the following packages are not installed. No
    links will be generated to these packages: base-4.2.0.2, ffi-1.0, rts-1.0,
    ghc-prim-0.2.0.0, integer-gmp-0.2.0.1
    Warning: GHC.Paths: could not find link destinations for:
        GHC.IO.FilePath
    

Change History (4)

comment:1 Changed 4 years ago by claus

Please note that this ticket is relevant for the upcoming 7.x release, as it seems to have its cause in the release process.

Since you are drowning in tickets, I collected several related issues in this one. Most of them seem to be caused by directory layout changes that are not reflected in the release process, and not communicated to package info (4), haddock (5,6), installer builder (2).

That means they may not be hard to fix, and may affect other platforms as well (the library documentation problems, in particular).

comment:2 Changed 4 years ago by simonmar

  • Milestone set to 7.0.1
  • Owner set to igloo
  • Priority changed from normal to high

1-2 look to be non-critical, and 3 is not an issue (your local package DB is not part of the GHC install, so is not removed when you uninstall).

4-6 look to be critical though, so raising priority.

Claus: I appreciate the effort to keep the number of tickets down, but it is actually more helpful for us if we have one ticket per issue, so we can prioritise and tackle them separately. Let's separate the issues in this ticket after Ian has had a look and decided what needs to be done.

comment:3 Changed 4 years ago by claus

1 means that I can't even install 6.12.3 and the 7RC side-by-side, not to mention HP releases, 2 means that '.hs' files have no icon because the installer refers to a non-existent directory (oddly enough, the GHCi executable seems to have its own embedded icon?).

Anyway, I agree that 4-6 are more criticial.

All issues are still present with ghc-7.0.0.20100925-i386-windows.exe.

Btw, I thought your builders now tested binary releases - couldn't you add a link checker (#1574) to those tests now?

comment:4 Changed 4 years ago by igloo

  • Resolution set to fixed
  • Status changed from new to closed

1 already has another ticket.

I've filed #4352 for 2.

3 isn't an issue, as Simon said.

I've pushed a patch for 4:

Wed Sep 29 14:33:28 BST 2010  Ian Lynagh <igloo@earth.li>
  * Fix the doc directory on Windows

which I assume will also fix 6.

I can't see what you mean by 5 in 7.0.1 RC 1. Can you please file another ticket if you still think there's a problem, giving more detail on exactly what is wrong?

Note: See TracTickets for help on using tickets.