Opened 5 years ago

Closed 5 years ago

#4231 closed bug (duplicate)

Cannot build ghc-6.13.20100729 HEAD package in Mac OS X Leopard

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.13
Keywords: Cc:
Operating System: MacOS X Architecture: x86_64 (amd64)
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description (last modified by igloo)

Mac OS X Leopard. Uname -a: 
Darwin ip-XXX-XXX-XXX-XXX.xxx.xxx.com.br 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386

GHC HEAD -, got using darcs in  07/30/2010:

  $ darcs get --lazy http://darcs.haskell.org/ghc
  $ cd ghc
  $ chmod +x darcs-all
  $ ./darcs-all --testsuite get

"./configure" output:

checking for gfind... no
checking for find... /usr/bin/find
checking for sort... /usr/bin/sort
checking for GHC version date... inferred 6.13.20100729
checking for ghc... /usr/bin/ghc
checking version of ghc... 6.12.3
checking build system type... i386-apple-darwin9.8.0
checking host system type... i386-apple-darwin9.8.0
checking target system type... i386-apple-darwin9.8.0
Build platform inferred as: i386-apple-darwin
Host platform inferred as: i386-apple-darwin
Target platform inferred as: i386-apple-darwin
checking for nhc... no
checking for nhc98... no
checking for hbc... no
checking for path to top of build tree... /Users/llvm/Downloads/ghc
checking for gcc... /usr/bin/gcc
checking for ld... /usr/bin/ld
checking for nm... /usr/bin/nm
checking Mac OS X deployment target... none
checking whether #! works in shell scripts... yes
checking for perl... /opt/local/bin/perl
checking if your perl works in shell scripts... yes
checking for python... /usr/bin/python
checking for gcc... /usr/bin/gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /usr/bin/gcc accepts -g... yes
checking for /usr/bin/gcc option to accept ISO C89... none needed
checking version of gcc... 4.0.1
checking for extra options to pass gcc when compiling via C...  -fwrapv -mno-omit-leaf-frame-pointer -fno-unit-at-a-time -fno-stack-protector
checking how to run the C preprocessor... /usr/bin/gcc -E
checking for a working context diff... diff -U 1
checking for a BSD-compatible install... /usr/bin/install -c
checking for ar... /usr/bin/ar
checking whether /usr/bin/ar is GNU ar... no
checking for ar arguments... clqs
checking whether /usr/bin/ar supports @file... no
checking whether ranlib is needed... yes
checking for ranlib... ranlib
checking whether /usr/bin/ar supports -input... no
checking whether ln -s works... yes
checking for gsed... no
checking for sed... /usr/bin/sed
checking for time... /usr/bin/time
checking for gnutar... /usr/bin/gnutar
checking for gpatch... no
checking for patch... /usr/bin/patch
checking for dtrace... /usr/sbin/dtrace
checking for HsColour... no
checking for xmllint... /opt/local/bin/xmllint
checking for DocBook DTD... ok
checking for xsltproc... /opt/local/bin/xsltproc
checking for DocBook XSL stylesheet... yes
checking for dblatex... no
configure: WARNING: cannot find dblatex in your PATH, you will not be able to build the PDF and PS documentation
checking for hasktags... no
configure: WARNING: cannot find hasktags in your PATH, you will not be able to build the tags
checking for ghc-pkg matching /usr/bin/ghc... /usr/bin/ghc-pkg
checking for happy... /opt/cabal/bin/happy
checking for version of happy... 1.18.5
checking for alex... /opt/cabal/bin/alex
checking for version of alex... 2.3.3
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ANSI C header files... yes
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking bfd.h usability... no
checking bfd.h presence... no
checking for bfd.h... no
checking ctype.h usability... yes
checking ctype.h presence... yes
checking for ctype.h... yes
checking dirent.h usability... yes
checking dirent.h presence... yes
checking for dirent.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking errno.h usability... yes
checking errno.h presence... yes
checking for errno.h... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking grp.h usability... yes
checking grp.h presence... yes
checking for grp.h... yes
checking limits.h usability... yes
checking limits.h presence... yes
checking for limits.h... yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking nlist.h usability... yes
checking nlist.h presence... yes
checking for nlist.h... yes
checking pthread.h usability... yes
checking pthread.h presence... yes
checking for pthread.h... yes
checking pwd.h usability... yes
checking pwd.h presence... yes
checking for pwd.h... yes
checking signal.h usability... yes
checking signal.h presence... yes
checking for signal.h... yes
checking sys/cpuset.h usability... no
checking sys/cpuset.h presence... no
checking for sys/cpuset.h... no
checking sys/mman.h usability... yes
checking sys/mman.h presence... yes
checking for sys/mman.h... yes
checking sys/resource.h usability... yes
checking sys/resource.h presence... yes
checking for sys/resource.h... yes
checking sys/select.h usability... yes
checking sys/select.h presence... yes
checking for sys/select.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking sys/timeb.h usability... yes
checking sys/timeb.h presence... yes
checking for sys/timeb.h... yes
checking sys/timers.h usability... no
checking sys/timers.h presence... no
checking for sys/timers.h... no
checking sys/times.h usability... yes
checking sys/times.h presence... yes
checking for sys/times.h... yes
checking sys/utsname.h usability... yes
checking sys/utsname.h presence... yes
checking for sys/utsname.h... yes
checking sys/wait.h usability... yes
checking sys/wait.h presence... yes
checking for sys/wait.h... yes
checking termios.h usability... yes
checking termios.h presence... yes
checking for termios.h... yes
checking time.h usability... yes
checking time.h presence... yes
checking for time.h... yes
checking utime.h usability... yes
checking utime.h presence... yes
checking for utime.h... yes
checking windows.h usability... no
checking windows.h presence... no
checking for windows.h... no
checking winsock.h usability... no
checking winsock.h presence... no
checking for winsock.h... no
checking sched.h usability... yes
checking sched.h presence... yes
checking for sched.h... yes
checking whether time.h and sys/time.h may both be included... yes
checking for long long... yes
checking size of char... 1
checking size of double... 8
checking size of float... 4
checking size of int... 4
checking size of long... 4
checking size of long long... 8
checking size of short... 2
checking size of unsigned char... 1
checking size of unsigned int... 4
checking size of unsigned long... 4
checking size of unsigned long long... 8
checking size of unsigned short... 2
checking size of void *... 4
checking for char... yes
checking alignment of char... 1
checking for double... yes
checking alignment of double... 4
checking for float... yes
checking alignment of float... 4
checking for int... yes
checking alignment of int... 4
checking for long... yes
checking alignment of long... 4
checking for long long... (cached) yes
checking alignment of long long... 4
checking for short... yes
checking alignment of short... 2
checking for unsigned char... yes
checking alignment of unsigned char... 1
checking for unsigned int... yes
checking alignment of unsigned int... 4
checking for unsigned long... yes
checking alignment of unsigned long... 4
checking for unsigned long long... yes
checking alignment of unsigned long long... 4
checking for unsigned short... yes
checking alignment of unsigned short... 2
checking for void *... yes
checking alignment of void *... 4
checking for WinExec... no
checking for GetModuleFileName... no
checking return type of signal handlers... void
checking for getclock... no
checking for getrusage... yes
checking for gettimeofday... yes
checking for setitimer... yes
checking for siginterrupt... yes
checking for sysconf... yes
checking for times... yes
checking for ctime_r... yes
checking for sched_setaffinity... no
checking for setlocale... yes
checking whether ctime_r is declared... yes
checking for closedir in -lmingwex... no
checking for library containing atan... none required
checking for xmalloc in -liberty... no
checking for bfd_init in -lbfd... no
checking for dlopen in -ldl... yes
checking for working alloca.h... yes
checking for alloca... yes
checking for pid_t... yes
checking vfork.h usability... no
checking vfork.h presence... no
checking for vfork.h... no
checking for fork... yes
checking for vfork... yes
checking for working fork... yes
checking for working vfork... (cached) yes
checking for an ANSI C-conforming const... yes
checking whether byte ordering is bigendian... no
checking whether float word order is big endian... no
checking for nlist in -lelf... no
checking leading underscore in symbol names... yes
checking whether ld understands -x... yes
checking whether ld is GNU ld... no
checking for .subsections_via_symbols... yes
checking for GNU non-executable stack support... no
checking for clock_gettime in -lrt... no
checking for clock_gettime... no
checking for timer_create... no
checking for timer_settime... no
checking for a working timer_create(CLOCK_REALTIME)... no
checking for printf$LDBLStub... no
checking for pkg-config... /opt/local/bin/pkg-config
checking for PAPI_library_init in -lpapi... no
checking papi.h usability... no
checking papi.h presence... no
checking for papi.h... no
checking for __mingw_vfprintf... no
configure: creating ./config.status
config.status: creating mk/config.mk
config.status: creating mk/install.mk
config.status: creating mk/project.mk
config.status: creating compiler/ghc.cabal
config.status: creating ghc/ghc-bin.cabal
config.status: creating ghc.spec
config.status: creating extra-gcc-opts
config.status: creating docs/users_guide/ug-book.xml
config.status: creating docs/users_guide/ug-ent.xml
config.status: creating docs/index.html
config.status: creating libraries/prologue.txt
config.status: creating distrib/ghc.iss
config.status: creating distrib/configure.ac
config.status: creating mk/config.h
config.status: executing mk/stamp-h commands

----------------------------------------------------------------------
Configure completed successfully.

   Building GHC version  : 6.13.20100729

   Build platform        : i386-apple-darwin
   Host platform         : i386-apple-darwin
   Target platform       : i386-apple-darwin

   Bootstrapping using   : /usr/bin/ghc
      which is version   : 6.12.3

   Using GCC             : /usr/bin/gcc
      which is version   : 4.0.1

   ld       : /usr/bin/ld
   Happy    : /opt/cabal/bin/happy (1.18.5)
   Alex     : /opt/cabal/bin/alex (2.3.3)
   Python   : /usr/bin/python
   Perl     : /opt/local/bin/perl
   dblatex  : 
   xsltproc : /opt/local/bin/xsltproc

   HsColour was not found; documentation will not contain source links

   Building DocBook HTML documentation : YES
   Building DocBook PS documentation   : NO
   Building DocBook PDF documentation  : NO
----------------------------------------------------------------------

Errors ocurred:

Loading package Cabal-1.9.2 ... linking ... ghc-stage2: internal error: Invalid Mach-O file:Address out of bounds while relocating object file
    (GHC version 6.13.20100729 for i386_apple_darwin)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
make[1]: *** [libraries/dph/dph-seq/dist-install/build/Data/Array/Parallel/Lifted/PArray.o] Abort trap

haddock: internal error: Invalid Mach-O file:Address out of bounds while relocating object file
    (GHC version 6.13.20100729 for i386_apple_darwin)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
make[1]: *** [libraries/dph/dph-seq/dist-install/doc/html/dph-seq/dph-seq.haddock] Abort trap

finally built and installed with:

$ make -k
$ make -k install

Change History (2)

comment:1 Changed 5 years ago by igloo

  • Description modified (diff)

comment:2 Changed 5 years ago by igloo

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report. This is a duplicate of #4013.

Note: See TracTickets for help on using tickets.