Opened 5 years ago

Closed 5 years ago

#4217 closed bug (duplicate)

Haskell Platform for Mac depends on a non-standard /opt/local/bin/perl

Reported by: zooko Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.12.3
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:


$ /Library/Frameworks/GHC.framework/Versions/612/usr/lib/ghc-6.12.3/ghc-asm /Library/Frameworks/GHC.framework/Versions/612/usr/lib/ghc-6.12.3/ghc-asm: /opt/local/bin/perl: bad interpreter: No such file or directory

Making a symlink from /opt/local/bin/perl to the standard (on OS X) /usr/bin/perl seems to have solved the problem.

Change History (1)

comment:1 Changed 5 years ago by igloo

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report. Fixed (duplicate of #4183).

Note: See TracTickets for help on using tickets.