Opened 5 years ago

Closed 3 years ago

#4062 closed bug (invalid)

Bad choice of loop breaker?

Reported by: rl Owned by: rl
Priority: normal Milestone: 7.2.1
Component: Compiler Version: 6.13
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Runtime performance bug Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

When compiling dph-prim-par/Data/Array/Parallel/Unlifted/Distributed/Arrays.hs, GHC chooses splitD (only until w/w) and splitJoinD as loop breakers which prevents the latter from being inlined in other modules. I fear this might actually be the correct behaviour but Simon asked me to submit a ticket so here it is. I fixed the problem by moving the implementation of splitD to a new function splitD_impl which is called from splitD and splitJoinD. I haven't pushed the patch yet; I'll tag the repo and update the ticket before I do that.

Change History (5)

comment:1 Changed 5 years ago by simonpj

Roman, I think you've added splitD_impl to the repo, so I can't reproduce the problem any more.

Simon

comment:2 Changed 5 years ago by igloo

  • Milestone set to 6.14.1
  • Owner set to rl

Assigning to rl to "tag the repo and update the ticket".

comment:3 Changed 4 years ago by igloo

  • Milestone changed from 7.0.1 to 7.0.2

comment:4 Changed 4 years ago by igloo

  • Milestone changed from 7.0.2 to 7.2.1

comment:5 Changed 3 years ago by igloo

  • Resolution set to invalid
  • Status changed from new to closed

No testcase, so closing

Note: See TracTickets for help on using tickets.