Opened 9 years ago

Closed 9 years ago

Last modified 44 years ago

#381 closed bug (Fixed)

System.Posix.Signals.setStoppedChildFlag segfaults

Reported by: nobody Owned by: nobody
Priority: normal Milestone:
Component: hslibs/posix Version: 6.4
Keywords: Cc:
Operating System: Architecture:
Type of failure: Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

On GHC6.4 System.Posix.Signals.setStoppedChildFlag causes the 
program to segfault (x86/Debian). The following simple program 
triggers it:

import System.Posix.Signals
main = setStoppedChildFlag True


Change History (1)

comment:1 Changed 9 years ago by simonmar

  • Status changed from assigned to closed
Logged In: YES 
user_id=48280

Fixed - this was caused by the breakage to foreign import
"&".  I'm merging the fixes onto the 6.4 branch right now.
Note: See TracTickets for help on using tickets.