Opened 9 years ago

Closed 9 years ago

Last modified 44 years ago

#380 closed bug (Fixed)

ghc --make panic on fptools/ghc/compiler/Lexer.hs

Reported by: nobody Owned by: nobody
Priority: normal Milestone:
Component: Compiler Version: 6.4
Keywords: Cc:
Operating System: Architecture:
Type of failure: Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I am trying to use ghc's lexer in my own project. When
building module that imports Lexer module I am getting
this error:

ghc-6.4: panic! (the `impossible' happened, GHC version
6.4):
        expectJust upsweep_mod:old_linkable


My reproduction project(attached) consists of two files:

Main.hs
========>
module Main where



import Lexer



main = putStrLn "hello"
<=========
and Makefile.

You may have to edit Makefile to provide the correct
path to the fptools folder. Running make demonstrates
the error.

I am using ghc-6.4 on gentoo.

Thank you,
Pavel [pavelzolnikov at yahoo dot com]

Attachments (1)

ghce.2.zip (705 bytes) - added by nobody 9 years ago.

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by nobody

comment:1 Changed 9 years ago by simonmar

  • Status changed from assigned to closed
Logged In: YES 
user_id=48280

I believe this is an instance of a bug that has already been
fixed.  The problem is that modules referred to from the
.hi-boot files in GHC were not automatically being compiled
in.  It works with the latest GHC STABLE snapshot, anyway.

Also, I suspect that what you are doing is somewhat fragile:
those parts of GHC weren't really intended to be extracted
and used separately.  Have fun, but don't expect it to "just
work"!

Note: See TracTickets for help on using tickets.