Opened 9 years ago

Closed 9 years ago

Last modified 44 years ago

#376 closed bug (Works For Me)

Program aborts with segmentation fault when profiling used.

Reported by: nobody Owned by: nobody
Priority: normal Milestone:
Component: Profiling Version: None
Keywords: Cc:
Operating System: Architecture:
Type of failure: Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I have a program that I have compiled under ghc6.5
(downloaded from the CVS repository on May 5/6), on
Fedora-2 core running on a PC.  This will run fine when
compiled without profiling.  With profiling enabled
(-prof -auto-all with GHC, and +RTS -p for the
program), it aborts, with the message "internal error:
Segmentation fault".

The same program will compile and run, both with and
without profiling, under ghc6.2.1.  I have also tried
with different datasets, and the same pattern occurs.

I updated my ghc installation from CVS today (9th May),
but have not been able to update my ghc installation 
to see if this problem has been removed, as the
fptools-level build process is failing, with the
Haddock build complaining that parsec-1.0 is an unknown
package when building Utils.hs; building in the ghc dir
results in a failure to find a module Version when
building Main.hs in the utils/ghc-pkg area.

The program and dataset are contained in the attached
gzip'd tar file.  I compile it (without profiling) using

ghc --make -fglasgow-exts -o Reader Reader.hs

 

Attachments (1)

duke.2.tgz (6.9 KB) - added by nobody 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by nobody

comment:1 Changed 9 years ago by nobody

Logged In: NO 

Submitter forgot to add: contact email address is
David Duke, email djd@comp.leeds.ac.uk

comment:2 Changed 9 years ago by simonmar

Logged In: YES 
user_id=48280

I have not been able to reproduce this one, either with 6.4
or with HEAD of today (11/05).

Can you verify that it now works for you?

comment:3 Changed 9 years ago by simonmar

Logged In: YES 
user_id=48280

Closing: it worked for me, and the submitter has not
followed up.

comment:4 Changed 9 years ago by simonmar

  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.