Opened 7 years ago

Closed 19 months ago

Last modified 18 months ago

#3712 closed task (wontfix)

Implement -dynamic-lib option

Reported by: simonmar Owned by:
Priority: low Milestone: 8.0.1
Component: Compiler Version: 6.12.1 RC1
Keywords: Cc: dterei
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

The proposal is to add a new option -dynamic-lib, to be used when building a shared library. It would be both a compile-time and a link-time option, and could be used with --make to build a complete shared library in one go. It would avoid the pitfalls caused by there being combinations of -dynamic and -fPIC don't do what the user expects.

Specifically, -dynanmic-lib would imply -dyanamic, -fPIC where necessary, and -shared when linking.

See #3705 for more discussion.

Change History (11)

comment:1 Changed 6 years ago by igloo

Milestone: 7.0.17.0.2

comment:2 Changed 6 years ago by igloo

Milestone: 7.0.27.2.1

comment:3 Changed 6 years ago by dterei

Cc: dterei added

comment:4 Changed 5 years ago by igloo

Milestone: 7.2.17.4.1

comment:5 Changed 5 years ago by igloo

Milestone: 7.4.17.6.1
Priority: normallow

comment:6 Changed 4 years ago by igloo

Milestone: 7.6.17.6.2

comment:7 Changed 3 years ago by thoughtpolice

Milestone: 7.6.27.10.1

Moving to 7.10.1.

comment:8 Changed 2 years ago by thoughtpolice

Milestone: 7.10.17.12.1

Moving to 7.12.1 milestone; if you feel this is an error and should be addressed sooner, please move it back to the 7.10.1 milestone.

comment:9 Changed 19 months ago by bgamari

Simon, do you intend on picking this up?

comment:10 Changed 19 months ago by simonmar

Resolution: wontfix
Status: newclosed

We probably don't need this; most people use Cabal which knows what to do.

comment:11 Changed 18 months ago by thoughtpolice

Milestone: 7.12.18.0.1

Milestone renamed

Note: See TracTickets for help on using tickets.