Opened 9 years ago

Closed 8 years ago

Last modified 44 years ago

#371 closed bug (Fixed)

segmentation fault

Reported by: zooko Owned by: simonmar
Priority: normal Milestone:
Component: None Version: None
Keywords: Cc:
Operating System: Architecture:
Type of failure: Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

http://bugs.darcs.net//Ticket/Display.html?id=367

Change History (6)

comment:1 Changed 9 years ago by simonmar

Logged In: YES 
user_id=48280

If the darcs devs can confirm that this is most likely a bug
in GHC, as opposed to a bug in darcs due to use of FFI or
unsafeWhatNot, then we'll look into it.  We need a repro
case (the repository that caused the failure, at least), and
the same darcs sources.


comment:2 Changed 9 years ago by zooko

Logged In: YES 
user_id=52562

For what it is worth, I haven't gotten any of these errors
since I stopped trying to use darcs on lots of large binary
patches containing 100's of MB per patch.

So I suspect the bug is triggered by certain memory usage
patterns...

comment:3 Changed 9 years ago by simonmar

Logged In: YES 
user_id=48280

Without a repeatable test case, there's nothing we can do
with this bug report, sorry.  If it reappears, feel free to
post more information and we can re-open the bug.

comment:4 Changed 8 years ago by zooko

Logged In: YES 
user_id=52562

Hooray!  A repeatable test case has been found!

http://bugs.darcs.net/issue8

comment:5 Changed 8 years ago by zooko

Logged In: YES 
user_id=52562

to reproduce:

1.  Download
http://prdownloads.sourceforge.net/jboss/jboss-4.0.3SP1.tar.bz2?download

2.  Untar it

3.  darcs initialize

4.  darcs record -al -m foo

Expected behavior: darcs records a massive patch adding all
of the contents to the repo.

Actual behavior: on Linux and Mac OS X darcs works as
expected.  On Windows it gives an error.  I believe the
error varies.  radekg reported this: http://bugs.darcs.net/msg20

I tried darcs 1.0.4. and got some uninformative error
message generated by darcs.  Then I tried darcs 1.0.3 and
got this:

darcs.exe: internal error: stg_ap_v_ret
    Please report this as a bug to
glasgow-haskell-bugs@haskell.org,
    or http://www.sourceforge.net/projects/ghc/


comment:6 Changed 8 years ago by simonmar

  • Status changed from assigned to closed
Logged In: YES 
user_id=48280

Fixed; this was a bug in the regex library distributed with
GHC.  The regex library originally comes from FreeBSD, and
it turns out the FreeBSD folks had already patched this
problem in a later revision, so I brought over the patch
(FreeBSD rev. 1.24 regcomp.c; GHC rev. 1.7).
Note: See TracTickets for help on using tickets.