Opened 9 years ago

Closed 8 years ago

Last modified 6 years ago

#370 closed bug (worksforme)

possible compacting GC bug in 6.4.x

Reported by: zooko Owned by: simonmar
Priority: high Milestone: 6.4.2
Component: Runtime System Version: 6.4.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Change History (10)

comment:1 Changed 9 years ago by simonmar

Logged In: YES 
user_id=48280

We need a repro case: a darcs repository from which to pull,
and the sources to the darcs version that exhibits the error.

comment:2 Changed 9 years ago by zooko

Logged In: YES 
user_id=52562

For what it is worth, I haven't gotten any of these errors
since I stopped trying to use darcs on lots of large binary
patches containing 100's of MB per patch.

So I suspect the bug is triggered by certain memory usage
patterns...

comment:3 Changed 9 years ago by simonmar

Logged In: YES 
user_id=48280

Without a repeatable test case, there's nothing we can do
with this bug report, sorry.  If it reappears, feel free to
post more information and we can re-open the bug.

comment:4 Changed 8 years ago by zooko

  • Status changed from assigned to closed
Logged In: YES 
user_id=52562

Hooray!  A repeatable test case has been found!

http://bugs.darcs.net/issue8

comment:5 Changed 8 years ago by nobody

Logged In: NO 

Likely the same bug as:

http://sourceforge.net/tracker/index.php?func=detail&aid=1194393&group_id=8032&atid=108032

comment:6 Changed 8 years ago by simonmar

  • Description modified (diff)
  • Milestone set to 6.4.2
  • Priority changed from normal to high
  • severity changed from normal to blocker
  • Version changed from None to 6.4.1

comment:7 Changed 8 years ago by simonmar

  • Architecture set to Unknown
  • Component changed from None to Runtime System
  • Description modified (diff)
  • Difficulty set to Unknown
  • Operating System set to Unknown
  • severity changed from blocker to critical
  • Summary changed from internal error in GHC to possible compacting GC bug in 6.4.x

Some notes on why this bug is still here: I suspect there is a bug in the compacting GC, at least in 6.4.x. I turned on compacting collection for stage 3 of the nightly builds, and we have seen crashes. However the bug has so far elluded my attempts to make it reproducible; the slightest change to the conditions makes it go away.

As of today, the bug is not affecting the nightly STABLE builds.

comment:8 Changed 8 years ago by simonmar

  • Resolution changed from None to worksforme
  • Status changed from assigned to closed

This has stopped happening for me. It was happening in the nightly builds a few months ago, but I was unable to reproduce it, and since then it has stopped occurring altogether. In the absence of a reproducible test case, we have to close the bug.

comment:9 Changed 6 years ago by simonmar

  • Architecture changed from Unknown to Unknown/Multiple

comment:10 Changed 6 years ago by simonmar

  • Operating System changed from Unknown to Unknown/Multiple
Note: See TracTickets for help on using tickets.