Opened 5 years ago

Closed 5 years ago

#3504 closed bug (fixed)

GHC panicks with a huge list in source code

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.10.4
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

Not sure if this is of any consequence, but I decided to generate some data as Haskell code direct, instead of loading it with 'properly', for test purposes. Removing some 50-80 lines from the file will result in ghc compiling it properly.

[1 of 1] Compiling Main ( testdata.hs, interpreted )
ghc: panic! (the 'impossible' happened)

(GHC version 6.10.4 for x86_64-unknown-linux):

linkBCO: >= 64k insns in BCO

Attachments (1)

testdata.hs.gz (10.2 KB) - added by guest 5 years ago.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by guest

comment:1 Changed 5 years ago by igloo

  • difficulty set to Unknown
  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the report. This is a duplicate of #789, and is fixed in the HEAD.

Note: See TracTickets for help on using tickets.