Opened 8 years ago

Closed 8 years ago

#3425 closed bug (invalid)

compileToCoreModule: ghc: panic! (the 'impossible' happened)

Reported by: iago Owned by:
Priority: normal Milestone: 6.12.1
Component: GHC API Version: 6.10.4
Keywords: Cc:
Operating System: Linux Architecture: x86_64 (amd64)
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

The following code on GHCi

runGhc (Just "/home/mads/iabal/opt/ghc-6.10.4/lib/ghc-6.10.4/.") (compileToCoreModule "./foo.hs")

causes a GHC Panic

ghc: panic! (the 'impossible' happened)
  (GHC version 6.10.4 for x86_64-unknown-linux):
        no package state yet: call GHC.setSessionDynFlags

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

foo.hs is attached.

Attachments (1)

foo.hs (154 bytes) - added by iago 8 years ago.
Causes ghc panic when trying to load it with compileToCoreModule

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by iago

Attachment: foo.hs added

Causes ghc panic when trying to load it with compileToCoreModule

comment:1 Changed 8 years ago by igloo

difficulty: Unknown
Milestone: 6.12.1

comment:2 Changed 8 years ago by simonmar

Resolution: invalid
Status: newclosed

This is not a bug: you have to perform a little set up before you can use the GHC API. See http://www.haskell.org/haskellwiki/GHC/As_a_library for more information.

Note: See TracTickets for help on using tickets.