Opened 8 years ago

Closed 8 years ago

#3405 closed bug (fixed)

ghc: panic! FamInstEnv.pprFamInstHdr

Reported by: dsf Owned by: chak
Priority: normal Milestone:
Component: Compiler Version: 6.10.4
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

I got this message during a compile:

Appraisal/Account/XML.hs:1:0:ghc: panic! (the 'impossible' happened)

(GHC version 6.10.4 for i386-unknown-linux):

FamInstEnv.pprFamInstHdr

Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

Unfortunately, I am unable to provide a simplified source file that reproduces the bug.

Change History (3)

comment:1 Changed 8 years ago by dsf

We believe this was probably caused by mixing compiled and loaded versions of the same packages. Whether it is "correct" for this to provoke to an impossible error I can not say.

comment:2 Changed 8 years ago by chak

Owner: set to chak

Thanks for the report. I think I know what the problem is.

(Note to self: Cover AbstractTyCon in that function by just printing data instance.)

comment:3 Changed 8 years ago by chak

Resolution: fixed
Status: newclosed

You may want to try your example with the current development version to verify that the issue has really been fixed.

Note: See TracTickets for help on using tickets.