Opened 10 years ago

Closed 10 years ago

Last modified 46 years ago

#329 closed bug (Fixed)

Panic while linking with hs-boot files

Reported by: yavorche Owned by: nobody
Priority: normal Milestone:
Component: Compiler Version: 6.4
Keywords: Cc:
Operating System: Architecture:
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

Hello,
GHC 6.4 panics while trying to link recursive hs-boot
files.
The problem is illustrated in the attached tar.gz file.
Just typing "make" should hopefully reporduce the problem.
I am using a Mandrake 10.1 linux distribution.
-Iavor

Attachments (1)

ghc-bug.tar.2.gz (10.0 KB) - added by yavorche 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by yavorche

comment:1 Changed 10 years ago by simonpj

  • Status changed from assigned to closed
Logged In: YES 
user_id=50165

Thanks for a well-characterised bug report.

The program is erroneous, becuase module B is not imported 
anywhere.
(It's only SOURCE imported, which isn't enough, because the 
main
source module will never be compiled.)   I'll add 
documentation on this point.

I've fixed the HEAD to check for this.

Actually, doing so showed up another bug, which I also fixed.


Note: See TracTickets for help on using tickets.