Opened 9 years ago

Closed 9 years ago

Last modified 44 years ago

#326 closed bug (Duplicate)

internal error: scavenge_mark_stack:

Reported by: ggd Owned by: simonmar
Priority: normal Milestone:
Component: None Version: None
Keywords: Cc:
Operating System: Architecture:
Type of failure: Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Hi!   
   
I 'patched' ghc-6.4 source with the latest Adjustor.c   
on the hope to get FFI support under amd64.   
   
However, attempt to compile gtk2hs gives:   
   
[...]   
  
make[2]: Leaving directory  
`/var/tmp/portage/gtk2hs-0.9.7/work/gtk2hs-0.9.7'  
if test -f glib/glib.precomp; then :; else make  
glib/glib.precomp; fi;  
make[2]: Entering directory  
`/var/tmp/portage/gtk2hs-0.9.7/work/gtk2hs-0.9.7'  
/var/tmp/portage/gtk2hs-0.9.7/work/gtk2hs-0.9.7/tools/c2hs/c2hsLocal  
+RTS -H300m -M350m -RTS  
-C-I/usr/include/glib-2.0 -C-I/usr/lib/glib-2.0/include  
--cppopts='-include "config.h"'  
--precomp=glib/glib.precomp glib-object.h  
elapsed time: 0.00 (start)  
elapsed time: 0.00 (about to parse headder)  
elapsed time: 3.11 (about to serialise header)  
c2hsLocal: internal error: scavenge_mark_stack:  
unimplemented/strange closure type -1780819864  
@ 0x2a95dad118  
    Please report this as a bug to  
glasgow-haskell-bugs@haskell.org,  
    or http://www.sourceforge.net/projects/ghc/  
make[2]: *** [glib/glib.precomp] Error 254  
make[2]: Leaving directory  
`/var/tmp/portage/gtk2hs-0.9.7/work/gtk2hs-0.9.7'  
make[1]: *** [glib/System/Glib/Types.hs] Error 2  
make[1]: Leaving directory  
`/var/tmp/portage/gtk2hs-0.9.7/work/gtk2hs-0.9.7'  
ghc-6.4: can't find file `glib/System/Glib/Types.hs'  
make: *** [glib/libHSglib_a.deps] Error 1  
make: *** Deleting file `glib/libHSglib_a.deps'  
  
 
Sincerely, 
Gour 
 

Change History (1)

comment:1 Changed 9 years ago by simonmar

  • Status changed from assigned to closed
Logged In: YES 
user_id=48280

Fixed (a duplicate of bug #1071030)
Note: See TracTickets for help on using tickets.