Opened 10 years ago

Closed 10 years ago

#3243 closed merge (fixed)

Forked gcc dies everytimes on Mac OS X 10.4.11

Reported by: nwn Owned by: igloo
Priority: normal Milestone: 6.10.4
Component: libraries/process Version: 6.10.3
Keywords: Cc:
Operating System: MacOS X Architecture: x86
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Forked gcc dies everytimes on Mac OS X 10.4.11, I saw this bug and reproduce it when building documents with haddock.

Details are described at http://www.haskell.org/pipermail/libraries/2009-May/011732.html

Attachments (1)

1242387095.dpatch (5.7 KB) - added by nwn 10 years ago.
patch to this bug, It works fine and passes tests

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by nwn

Attachment: 1242387095.dpatch added

patch to this bug, It works fine and passes tests

comment:1 Changed 10 years ago by simonmar

difficulty: Unknown
Owner: set to simonmar

We used to disable timers in the child of fork, but somehow that got lost between the version of process shipped with 6.8 and the one shipped with 6.10. I will look into what happened, there might be something else going on.

It might be that we haven't seen any problems because on Linux we're not using itimers any more, we're using timer_create().

comment:2 Changed 10 years ago by simonmar

Milestone: 6.10.4
Owner: changed from simonmar to igloo
Type: bugmerge

Fixed:

Wed May 20 03:31:39 PDT 2009  Simon Marlow <marlowsd@gmail.com>
  * Reinstate disableItimers() (#3243)

comment:3 Changed 10 years ago by igloo

Resolution: fixed
Status: newclosed

Merged.

Note: See TracTickets for help on using tickets.