Opened 5 years ago

Closed 5 years ago

#3183 closed bug (fixed)

unhelpful wording in module error message

Reported by: duncan Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.10.2
Keywords: Cc: doaitse@…
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Users sometimes hit this error message:

Could not find module `Control.Monad.State':
  it was found in multiple packages: monads-fd-0.0.0.1 mtl-1.1.0.2

The problem is just the wording. It should say from start that the module was found in multiple packages, rather than saying that it was not found at all.

How about:

Ambiguous module name `Control.Monad.State':
  it was found in multiple packages: monads-fd-0.0.0.1 mtl-1.1.0.2

We might also want the message to suggest the flags -hide-all-packages, -hide-package and/or -package as part of the solution.

I'm filing this on behalf of people who ran into this while building UHC (which does not use Cabal and does not use the -hide-all-packages flag).

Change History (1)

comment:1 Changed 5 years ago by igloo

  • Difficulty set to Unknown
  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the suggestion; fixed in the HEAD.

Note: See TracTickets for help on using tickets.