Opened 6 years ago

Closed 6 years ago

#3180 closed bug (duplicate)

TcTyFuns.flattenType: unexpected PredType

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.10.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

lguapo:inez cmoore$ ghci GHCi, version 6.10.1: http://www.haskell.org/ghc/ :? for help Loading package ghc-prim ... linking ... done. Loading package integer ... linking ... done. Loading package base ... linking ... done. Prelude> :m +NLP.WordNet Prelude NLP.WordNet> runWordNet ghc: panic! (the 'impossible' happened)

(GHC version 6.10.1 for i386-apple-darwin):

TcTyFuns.flattenType: unexpected PredType

Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

Prelude NLP.WordNet>

Change History (2)

comment:1 Changed 6 years ago by guest

Oops, let's try that again.

lguapo:inez cmoore$ ghci
GHCi, version 6.10.1: http://www.haskell.org/ghc/  :? for help
Loading package ghc-prim ... linking ... done.
Loading package integer ... linking ... done.
Loading package base ... linking ... done.
Prelude> :m +NLP.WordNet
Prelude NLP.WordNet> runWordNet
ghc: panic! (the 'impossible' happened)
  (GHC version 6.10.1 for i386-apple-darwin):
	TcTyFuns.flattenType: unexpected PredType

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Prelude NLP.WordNet> 

comment:2 Changed 6 years ago by chak

  • Resolution set to duplicate
  • Status changed from new to closed

You didn't provide any code for us to reproduce the bug. I'll assume that this is a duplicate of #3125, which has already been fixed in the development version. I'll close the bug for now. If you re-run you example with the current development version and still find an issue, please re-open the ticket.

Note: See TracTickets for help on using tickets.