Opened 5 years ago

Closed 5 years ago

#3158 closed bug (duplicate)

Linker error (libffi.so.5) in 6.10.2 x86-Linux binary distribution

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Runtime System Version: 6.10.2
Keywords: Cc:
Operating System: Linux Architecture: x86
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Hello,
I am running Debian Linux with the following uname(1):
Linux 2.6.18-6-686-bigmem #1 SMP Mon Aug 18 09:58:16 UTC 2008 i686 GNU/Linux

I downloaded the tarball "http://www.haskell.org/ghc/dist/6.10.2/ghc-6.10.2-i386-unknown-linux-libedit2.tar.bz2".
After doing "configure" and "make install", I got the following output:
<snip> Begin log </snip>

=======================================================================
Installation of ghc-6.10.2 was successful.
To use, add /h/uhs/pkg/ghc-6.10.2/bin to your PATH.
For documentation, see /h/uhs/pkg/ghc-6.10.2/share/doc/ghc/index.html
=======================================================================
haddock-2.4.2: dependency Cabal-1.6.0.3 doesn't exist (ignoring)
haddock-2.4.2: dependency array-0.2.0.0 doesn't exist (ignoring)
haddock-2.4.2: dependency base-4.1.0.0 doesn't exist (ignoring)
haddock-2.4.2: dependency containers-0.2.0.1 doesn't exist (ignoring)
haddock-2.4.2: dependency directory-1.0.0.3 doesn't exist (ignoring)
haddock-2.4.2: dependency filepath-1.1.0.2 doesn't exist (ignoring)
haddock-2.4.2: dependency ghc-6.10.2 doesn't exist (ignoring)
haddock-2.4.2: dependency haskell98-1.0.1.0 doesn't exist (ignoring)
haddock-2.4.2: dependency pretty-1.0.1.0 doesn't exist (ignoring)
rts-1.0: include-dirs: PAPI_INCLUDE_DIR doesn't exist or isn't a directory (ignoring)
ifBuildable/ifBuildable: error while loading shared libraries: libffi.so.5: cannot open shared object file: No such file or directory
[... Many identical lines ...]
ifBuildable/ifBuildable: error while loading shared libraries: libffi.so.5: cannot open shared object file: No such file or directory
ghc-6.10.2: dependency Cabal-1.6.0.3 doesn't exist (ignoring)
ghc-6.10.2: dependency array-0.2.0.0 doesn't exist (ignoring)
ghc-6.10.2: dependency base-4.1.0.0 doesn't exist (ignoring)
ghc-6.10.2: dependency bytestring-0.9.1.4 doesn't exist (ignoring)
ghc-6.10.2: dependency containers-0.2.0.1 doesn't exist (ignoring)
ghc-6.10.2: dependency directory-1.0.0.3 doesn't exist (ignoring)
ghc-6.10.2: dependency editline-0.2.1.0 doesn't exist (ignoring)
ghc-6.10.2: dependency filepath-1.1.0.2 doesn't exist (ignoring)
ghc-6.10.2: dependency haskell98-1.0.1.0 doesn't exist (ignoring)
ghc-6.10.2: dependency hpc-0.5.0.3 doesn't exist (ignoring)
ghc-6.10.2: dependency old-time-1.0.0.2 doesn't exist (ignoring)
ghc-6.10.2: dependency process-1.0.1.1 doesn't exist (ignoring)
ghc-6.10.2: dependency template-haskell-2.3.0.1 doesn't exist (ignoring)
ghc-6.10.2: dependency unix-2.3.2.0 doesn't exist (ignoring)

<snip> End log </snip>

I tried to start ghci and got:
<snip> Begin log </snip>

GHCi, version 6.10.2: http://www.haskell.org/ghc/ :? for help
ghc: panic! (the 'impossible' happened)

(GHC version 6.10.2 for i386-unknown-linux):

interactiveUI:setBuffering2[[BR]]


Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug[[BR]]

<snip> End log </snip>

The same process (download, configure, make, run) worked fine for the 6.10.1 x86-Linux binary distribution.

Change History (1)

comment:1 Changed 5 years ago by igloo

  • Difficulty set to Unknown
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report. You need to install the Debian libffi5 package.

Closing this ticket as it's a duplicate of #3151.

Note: See TracTickets for help on using tickets.