Opened 5 years ago

Closed 5 years ago

#3144 closed bug (fixed)

ghc panic

Reported by: funmler Owned by:
Priority: normal Milestone: 6.10 branch
Component: Compiler Version: 6.10.2
Keywords: Cc: aruiz@…
Operating System: Linux Architecture: x86
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

ghci fails with

ghc: panic! (the 'impossible' happened)

(GHC version 6.10.2 for i386-unknown-linux):

interactiveUI:setBuffering2

Attachments (2)

config.log (8.8 KB) - added by funmler 5 years ago.
config-install-output.tar.gz (7.2 KB) - added by aruiz 5 years ago.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by funmler

comment:1 Changed 5 years ago by funmler

This using the 6.10.2 on a lenny debian install. Please let me know if you need more details.

comment:2 Changed 5 years ago by aruiz

  • Cc aruiz@… added

comment:3 Changed 5 years ago by fft1976

I can confirm this. (Prelude did not get installed?)

http://hackage.haskell.org/trac/ghc/ticket/3151

comment:4 Changed 5 years ago by igloo

  • Difficulty set to Unknown
  • Milestone set to 6.10 branch
  • Version changed from 6.10.1 to 6.10.2

Which bindist were you trying to install from?

Can you please redirect the "configure" and "make install" output to files and attach them?

Changed 5 years ago by aruiz

comment:5 Changed 5 years ago by fft1976

I'll follow up in my ticket (3151), but, at least in my case the causes must be the same:

PREFIX/lib/ghc-6.10.2 is missing lots of files

comment:6 follow-up: Changed 5 years ago by funmler

The bindist is
ghc-6.10.1-i386-unknown-linux-libedit2.tar.bz2

comment:7 in reply to: ↑ 6 Changed 5 years ago by funmler

Replying to funmler:

The bindist is
ghc-6.10.1-i386-unknown-linux-libedit2.tar.bz2

Sorry I meant 6.10.2
ghc-6.10.2-i386-unknown-linux-libedit2.tar.bz2

comment:8 Changed 5 years ago by funmler

  • Resolution set to fixed
  • Status changed from new to closed

Fixed by installing libffi5

Note: See TracTickets for help on using tickets.