Opened 7 years ago

Closed 7 years ago

#3047 closed bug (duplicate)

Panic! (the 'impossible' happened) :)

Reported by: bchallenor Owned by:
Priority: normal Milestone:
Component: GHCi Version: 6.8.2
Keywords: Cc:
Operating System: Windows Architecture: x86
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:


I was just coding up a solution to a Project Euler problem when the following occurred. I'm attaching the source file. It should be useful as it's very short (well, except for there being a 46KB list on one line).

I apologize if this is a duplicate, because I'm using a fairly old GHCi.

Cheers Ben

[1 of 1] Compiling Main ( C:/Users/Ben/Desktop/ProjectEuler/22.hs, i nterpreted ) : panic! (the 'impossible' happened)

(GHC version 6.8.2 for i386-unknown-mingw32):

linkBCO: >= 64k insns in BCO

Please report this as a GHC bug:

Attachments (1)

22.hs (45.5 KB) - added by bchallenor 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by bchallenor


comment:1 Changed 7 years ago by bchallenor

This could well be a duplicate of

comment:2 Changed 7 years ago by simonmar

  • difficulty set to Unknown
  • Resolution set to duplicate
  • Status changed from new to closed

dup of #789

Note: See TracTickets for help on using tickets.