Opened 6 years ago

Closed 6 years ago

Last modified 2 weeks ago

#3046 closed bug (duplicate)

Generalized newtype deriving with associated types

Reported by: LouisWasserman Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.10.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

When I have a

    class Foo a where
	type Bar a
	foobar :: a -> Bar a

an

instance Foo Fooey ...

and

newtype Fooey2 = F2 (Fooey) deriving (Foo) 

I expect the automatically generated deriving to include

type Bar Fooey2 = Bar Fooey

but this is not the case: I cannot get an associated type from a newtype to resolve to anything. My guess is that the combination of -XTypeFamilies and -XGeneralizedNewtypeDeriving is rare enough that this may simply not have been thought of yet, but it's something I'd like to see fixed.

Attachments (1)

Funky.hs (327 bytes) - added by LouisWasserman 6 years ago.
A test example.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by LouisWasserman

A test example.

comment:1 Changed 6 years ago by LouisWasserman

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 6 years ago by pumpkin

(duplicate of #2850 in case you find this one first)

comment:3 Changed 3 weeks ago by rwbarton

  • Type of failure set to None/Unknown

I don't think this is a duplicate of #2850, but I do think it is a duplicate of #8165.

comment:4 Changed 2 weeks ago by simonpj

Correct; #8165 is the relevant ticket, and has a good discussion string.

Simon

Note: See TracTickets for help on using tickets.