Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3044 closed bug (invalid)

NoImplicitPrelude being ignored by 6.10.1, works in 6.8.2

Reported by: fasta Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.10.1
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

~/bin/ghci -XNoImplicitPrelude Main.hs results in the module being loaded

Expected result: the module should fail saying that putStrLn cannot be found/is not in scope.

module Main where
import Foo
import qualified Prelude as P
main = P.putStrLn []
module Foo where
zork = putStrLn "hi"

Change History (2)

comment:1 Changed 5 years ago by fasta

  • Resolution set to invalid
  • Status changed from new to closed

comment:2 Changed 5 years ago by igloo

  • Difficulty set to Unknown

Was caused by already having a compiled Foo.o and Foo.hi.

Note: See TracTickets for help on using tickets.