Opened 5 years ago

Closed 5 years ago

#3040 closed bug (fixed)

make clean fails (in utils/hsc2hs?) on 6.10

Reported by: nr Owned by:
Priority: normal Milestone:
Component: Build System Version: 6.11
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

make clean halts with an error message. Here's the tail of the output:

make -C hpc clean
/home/nr/net/ghc/2009-feb-dias/libraries/cabal-bin /usr/bin/ghc /home/nr/net/ghc/2009-feb-dias/libraries/bootstrapping.conf 1.7.0 clean --distpref dist-inplace
cleaning...
/home/nr/net/ghc/2009-feb-dias/libraries/cabal-bin /usr/bin/ghc /home/nr/net/ghc/2009-feb-dias/libraries/bootstrapping.conf 1.7.0 clean --distpref dist-install
cleaning...
rm -f -rf install-inplace
make -C hsc2hs clean
make[2]: *** No rule to make target `clean'.  Stop.
make[1]: *** [clean.hsc2hs] Error 2
Failed making clean in utils: 1
make: *** [clean] Error 1
: nr@homedog 2958 

I ran darcs-all get but this left me with an empty utils/hsc2hs directory, which turned out to be the cause of the problem. Removing the empty directory and re-running darcs-all get solved the problem. Not sure if this one is likely to recur, but I thought you should know about it. Perhaps ./configure ought to fail if a directory that should be nonempty is found to be empty?

Change History (2)

comment:1 Changed 5 years ago by nr

  • Version changed from 6.10.1 to 6.11

comment:2 Changed 5 years ago by simonmar

  • Difficulty set to Unknown
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in the new build system:

Tue Mar  3 16:07:59 GMT 2009  Simon Marlow <marlowsd@gmail.com>
  * FIX #3040: test for $dir/ghc.mk instead of just $dir
  catches cases where darcs has failed and left an empty directory
Note: See TracTickets for help on using tickets.