Opened 7 years ago

Closed 7 years ago

#3010 closed bug (duplicate)

"RegAllocLinear.getStackSlotFor: out of stack slots" ghc 6.10.1 for i386-unknown-mingw32 compiling Crypto-4.1.0

Reported by: agocorona Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.10.1
Keywords: Cc:
Operating System: Windows Architecture: x86
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Revisions:

Description

compiling Crypto-4.1.0 .............. ............... [1 of 4] Compiling Codec.Utils ( Codec\Utils.hs, dist\build\SHA1Test\SHA1Te st-tmp\Codec\Utils.o ) [2 of 4] Compiling Data.Digest.SHA1 ( Data\Digest\SHA1.hs, dist\build\SHA1Test\S HA1Test-tmp\Data\Digest\SHA1.o ) [3 of 4] Compiling Codec.Text.Raw ( Codec\Text\Raw.hs, dist\build\SHA1Test\SHA 1Test-tmp\Codec\Text\Raw.o ) [4 of 4] Compiling Main ( SHA1Test.hs, dist\build\SHA1Test\SHA1Test- tmp\Main.o ) ghc.exe: panic! (the 'impossible' happened)

(GHC version 6.10.1 for i386-unknown-mingw32):

RegAllocLinear.getStackSlotFor: out of stack slots, try -fregs-graph

Change History (1)

comment:1 Changed 7 years ago by Deewiant

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3006, #2967, #2919, #2771, and #2753.

Note: See TracTickets for help on using tickets.