Opened 5 years ago

Closed 5 years ago

#3006 closed bug (duplicate)

ghc panic when build Crypto package on Mac OS X 10.4

Reported by: alexott Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.10.1
Keywords: Cc:
Operating System: MacOS X Architecture: x86
Type of failure: Difficulty:
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I build Crypto package on Mac OS X 10.4 and got following error:

[4 of 4] Compiling Main             ( SHA1Test.hs, dist/build/SHA1Test/SHA1Test-tmp/Main.o )
ghc: panic! (the 'impossible' happened)
  (GHC version 6.10.1 for i386-apple-darwin):
        RegAllocLinear.getStackSlotFor: out of stack slots, try -fregs-graph

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

Change History (1)

comment:1 Changed 5 years ago by Deewiant

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2967, #2919, #2771, and #2753.

Note: See TracTickets for help on using tickets.