Opened 9 years ago

Closed 9 years ago

#2919 closed bug (duplicate)

ghc panic while compiling Crypto

Reported by: wchogg Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.10.1
Keywords: Cc:
Operating System: Linux Architecture: x86
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

While compiling the Crypto 4.1.0 library from hackage I received the following error

[4 of 4] Compiling Main ( SHA1Test.hs, dist/build/SHA1Test/SHA1Test-tmp/Main.o ) ghc: panic! (the 'impossible' happened)

(GHC version 6.10.1 for i386-unknown-linux):

RegAllocLinear.getStackSlotFor: out of stack slots, try -fregs-graph

Please report this as a GHC bug: http://www.haskell.org/ghc/reportabug

What more information will be useful?

Change History (2)

comment:1 Changed 9 years ago by StephenBlackheath

Workaround:

cabal install Crypto --disable-optimization

comment:2 Changed 9 years ago by igloo

difficulty: Unknown
Resolution: duplicate
Status: newclosed

Thanks for the report; this is a duplicate of #2753.

Note: See TracTickets for help on using tickets.