Opened 7 years ago

Closed 7 years ago

#2771 closed bug (duplicate)

GHC fail to Compile Crypto

Reported by: aivuk Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.10.1
Keywords: Cc:
Operating System: Linux Architecture: x86
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):


When I tried to compile Crypto lib in a MSI Wind notebook with Arch Linux, an error happens in Main compilation:

Configuring Crypto-4.1.0...
Warning: No 'build-type' specified. If you do not need a custom Setup.hs or
./configure script then use 'build-type: Simple'.
Preprocessing library Crypto-4.1.0...
Preprocessing executables for Crypto-4.1.0...
Building Crypto-4.1.0...
/usr/bin/ar: creating dist/build/libHSCrypto-4.1.0.a
[4 of 4] Compiling Main             ( SHA1Test.hs, dist/build/SHA1Test/SHA1Test-tmp/Main.o )
ghc: panic! (the 'impossible' happened)
  (GHC version 6.10.1 for i386-unknown-linux):
	RegAllocLinear.getStackSlotFor: out of stack slots, try -fregs-graph

I compiled the same lib in a Arch box, but in x86_64 arch without problems. I'm compiling using the Arch package haskell-crypto in both cases.

Change History (2)

comment:1 Changed 7 years ago by jimstutt

Ditto with darcs, hackage and aur versions on archlinux 2-6-27-ARCH ghc 6.10.1 unknown-linux on x86.

comment:2 Changed 7 years ago by Deewiant

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2753.

Note: See TracTickets for help on using tickets.