Opened 5 years ago

Closed 5 years ago

#2746 closed bug (fixed)

Documentation for Haskell 98 modules is empty

Reported by: simonmar Owned by:
Priority: high Milestone: 6.10.2
Component: Documentation Version: 6.10.1
Keywords: Cc: david.waern@…
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

How did this happen?

http://www.haskell.org/ghc/docs/6.10.1/html/libraries/haskell98/Char.html

in 6.8.3 at least we could see the exports, with hyperlinks to the actual docs:

http://www.haskell.org/ghc/docs/6.8.3/html/libraries/haskell98/Char.html

Also, #2337 seems to have regressed again, I imagine the cause is probably the same.

Change History (6)

comment:1 Changed 5 years ago by waern

I have fixed this problem in Haddock, so we now link to the docs for each export. However, the links sometimes go to the wrong place due to a bug in GHC where the options specified with OPTIONS_HADDOCK seem to go unnoticed. Currently investigating...

comment:2 Changed 5 years ago by igloo

HEAD now has:

Fri Jan  2 21:38:27 GMT 2009  David Waern <david.waern@gmail.com>
  * Show re-exported names from external packages again
  
  This fixes GHC ticket 2746.
  
  In order to also link to the exported subordinate names of a declaration, we
  need to re-introduce the sub map in the .haddock files.

comment:3 Changed 5 years ago by igloo

comment:4 Changed 5 years ago by waern

Ok, so the problem with links that goes to the wrong place is now fixed with this patch (in the HEAD):

Wed Jan  7 00:34:17 CET 2009  David Waern <david.waern@gmail.com>        
  * Do not process boot modules
  
  We should of course not try to produce documentation for boot modules! The
  reason this has worked in the past is that the output of "real" modules
  overwrites the output of boot modules later in the process. However, this
  causes a subtle link environment problem. So let's get rid of this stupid
  behaviour.
    
  We avoid processing boot modules, but we continue to typecheck them.

So that was a Haddock bug and not a GHC one.

Now Char from haskell98 has links to definitions in Data.Char and GHC.Types.

Will tackle CTypes and the likes next.

comment:5 Changed 5 years ago by waern

Module exports now works again, with this patch which is in HEAD:

Thu Jan  8 19:03:36 CET 2009  David Waern <david.waern@gmail.com>        
  * Export modules also when coming from external packages

comment:6 Changed 5 years ago by igloo

  • Resolution set to fixed
  • Status changed from new to closed

Now working in 6.10 branch and HEAD. Thanks, David!

Note: See TracTickets for help on using tickets.