Opened 6 years ago

Closed 6 years ago

#2509 closed bug (fixed)

ghc-pkg uses wrong package.conf

Reported by: judah Owned by:
Priority: normal Milestone: 6.10.1
Component: Compiler Version: 6.9
Keywords: Cc:
Operating System: MacOS X Architecture: x86
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

After installing HEAD ghc, running ghc-pkg lists no packages (not even base or rts):

$ /Users/judah/tmp/ghc-stage/bin/ghc-pkg list
/Users/judah/tmp/ghc-stage/share/ghc-6.9.20080809/ghc-pkg-6.9/package.conf:

The problem is that utils/ghc-pkg/ghc-pkg.wrapper points to the $datadir of ghc-pkg, which is the ghc-stage/share/[etc] folder listed above; whereas the package database used by ghc is instead:

/Users/judah/tmp/ghc-stage/lib/ghc-6.9.20080809/package.conf

Change History (1)

comment:1 Changed 6 years ago by igloo

  • Difficulty set to Unknown
  • Milestone set to 6.10.1
  • Resolution set to fixed
  • Status changed from new to closed

Coincidentally, I was fixing this earlier today. I've just pushed the fix, so it should work now.

Note: See TracTickets for help on using tickets.