Opened 6 years ago

Closed 4 years ago

#2476 closed bug (worksforme)

internal error: awaitEvent: descriptor out of range

Reported by: newsham Owned by:
Priority: low Milestone: 7.0.1
Component: Runtime System Version: 6.8.2
Keywords: Cc:
Operating System: FreeBSD Architecture: ia64
Type of failure: None/Unknown Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description (last modified by igloo)

My program reports:

Server3s.exe: internal error: awaitEvent: descriptor out of range
    (GHC version 6.8.2 for x86_64_unknown_freebsd)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
Abort trap: 6 (core dumped)

The core dump shows:

(gdb) where
#0  0x0000000800956dec in kill () from /lib/libc.so.7
#1  0x0000000800955c5b in abort () from /lib/libc.so.7
#2  0x00000000004e5bcd in rtsFatalInternalErrorFn ()
#3  0x00000000004e58bc in barf ()
#4  0x00000000004ea57d in awaitEvent ()
#5  0x00000000004e6d85 in scheduleWaitThread ()
#6  0x00000000004e42a9 in real_main ()
#7  0x00000000004e4398 in main ()

My host is:

FreeBSD hpsux 7.0-RELEASE FreeBSD 7.0-RELEASE #0: Sat Mar  8 14:07:11 HST 2008     root@hpsux:/usr/obj/usr/src/sys/GENERIC  amd64

The full sources that are causing this issue are attached. To reproduce: run "make" then in one window run "./Server3s.exe" and in another window run "./DummyClient3s.exe". I get the crash in the Server3s program after it runs for a while.

I can provide built binaries and a core dump if it is helpful. I didn't include them yet because they are large.

Attachments (1)

crash.tgz (4.3 KB) - added by newsham 6 years ago.
Sources that cause reproducable crash.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by newsham

Sources that cause reproducable crash.

comment:1 Changed 6 years ago by igloo

  • Description modified (diff)
  • Difficulty set to Unknown

comment:2 Changed 6 years ago by igloo

  • Milestone set to 6.10.1

I can't reproduce this on amd64/Linux; after a while it dies with:

DummyClient3s.exe: connect: unsupported operation (Cannot assign requested address)

strace shows that this is caused by:

connect(3, {sa_family=AF_INET, sin_port=htons(8001), sin_addr=inet_addr("127.0.0.1")}, 16) = -1 EADDRNOTAVAIL (Cannot assign requested address)

comment:3 Changed 6 years ago by igloo

  • Milestone changed from 6.10.1 to 6.10 branch

comment:4 Changed 5 years ago by igloo

  • Milestone changed from 6.10 branch to 6.12 branch

comment:5 Changed 4 years ago by igloo

  • Milestone changed from 6.12 branch to 6.12.3

comment:6 Changed 4 years ago by igloo

  • Milestone changed from 6.12.3 to 6.14.1
  • Priority changed from normal to low

comment:7 Changed 4 years ago by simonmar

  • Resolution set to worksforme
  • Status changed from new to closed
  • Type of failure set to None/Unknown

old bug, and we couldn't reproduce it. As usual, please re-open if you have a more recent instance and/or can supply more info.

Note: See TracTickets for help on using tickets.