Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#2454 closed bug (duplicate)

Closing handle from runInteractiveProcess causes myserious, uncatchable death.

Reported by: cjs Owned by:
Priority: normal Milestone:
Component: libraries/base Version: 6.8.3
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: x86
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Running the attached program on Windows works, because runInteractiveProcess fails. Under Linux and NetBSD, runIntractiveProcess returns (which it probably shouldn't--wouldn't it be nicer if it checked that it had execute access on what it wanted to exec before it forked?) and then at some point in hClose the program silently dies, though returning an error code to the process that spawned it.

Attachments (1)

SilentClose.hs (426 bytes) - added by cjs 6 years ago.
Program to demonstrate hClose silent failure.

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by cjs

Program to demonstrate hClose silent failure.

comment:1 Changed 6 years ago by simonmar

  • Difficulty set to Unknown
  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #1619, now fixed. Thanks anyway for a nice report!

comment:2 Changed 6 years ago by simonmar

  • Operating System changed from Multiple to Unknown/Multiple
Note: See TracTickets for help on using tickets.