Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2379 closed bug (wontfix)

ghc-6.9.20080614: panic! (the 'impossible' happened)

Reported by: megacz Owned by:
Priority: low Milestone: 6.10.1
Component: Compiler Version: 6.9
Keywords: Cc:
Operating System: MacOS X Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by igloo)

[ 7 of 78] Compiling Data.Array.Parallel.Base.Rebox ( Data/Array/Parallel/Base/Rebox.hs, dist/build/Data/Array/Parallel/Base/Rebox.o )
ghc-6.9.20080614: panic! (the 'impossible' happened)
  (GHC version 6.9.20080614 for i386-apple-darwin):
	initC: srt_lbl

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

<<ghc: 85934552 bytes, 26 GCs, 2419370/5914624 avg/max bytes residency (3 samples), 11M in use, 0.00 INIT (0.00 elapsed), 0.17 MUT (1.05 elapsed), 0.08 GC (0.09 elapsed) :ghc>>

Change History (5)

comment:1 Changed 9 years ago by simonpj

difficulty: Unknown

Is your source tree fully up to date? This was fixed recently, I think.

I think this was the patch

Sat Jun 14 03:39:37 GMT Daylight Time 2008  simonpj@microsoft.com
  * Fix nasty Simplifier scoping bug

Pls close if that's all it was.

Simon

comment:2 Changed 9 years ago by igloo

Description: modified (diff)
Milestone: 6.10.1
Priority: normallow

And if it is still broken for you, can you please attach the source code you were trying to compile and tell us what the commandline was?

comment:3 Changed 9 years ago by megacz

Resolution: wontfix
Status: newclosed

Sorry about the slow reply.

I've tried updating GHC to latest darcs, but now the NDP build fails at an earlier point ("cabal-bin: cabal: Don't know what to do!... Warning: Package is unbuildable"), so I can't tell if it helped or not.

So, I guess, close this bug since it can no longer be reproduced. Thanks for your time!

  • a

comment:4 Changed 9 years ago by simonpj

Ian and Roman are working on fixing the build-system problem.

Simon

comment:5 Changed 9 years ago by simonmar

Architecture: UnknownUnknown/Multiple
Note: See TracTickets for help on using tickets.