Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#2230 closed bug (worksforme)

ghci crashes with .o mismatches

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.8.2
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description (last modified by igloo)

Basic recipe is:

1) have multi-file program, compile with ghc --make (this creates some .o files in course of compilation)

2) edit some files and then run ghci and attempt to load main file with :l file.hs

3) ghci tries to load some of the compiled .o files, and crashes.

Workaround is to delete the .o's before running ghci.

Loading package binary-0.4.2 ... linking ... done.
<interactive>: internal error: loadObj: can't map `Records.o'
    (GHC version 6.8.2 for i386_unknown_linux)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
Aborted (core dumped)

Change History (4)

comment:1 Changed 6 years ago by igloo

  • Description modified (diff)
  • Difficulty set to Unknown

comment:2 Changed 6 years ago by igloo

  • Resolution set to worksforme
  • Status changed from new to closed

This works for me. If you can reproduce it, please reopen this bug and attach example code and some instructions that demonstrate the bug.

comment:3 Changed 6 years ago by simonmar

  • Architecture changed from Unknown to Unknown/Multiple

comment:4 Changed 6 years ago by simonmar

  • Operating System changed from Unknown to Unknown/Multiple
Note: See TracTickets for help on using tickets.