Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#2229 closed bug (duplicate)

ghc crashes on trying to build encoding module

Reported by: guest Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.8.2
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description (last modified by igloo)

It gets this far:

Building encoding-0.4...
[ 7 of 37] Compiling Data.Encoding.CP1258 ( Data/Encoding/CP1258.hs, dist/build/Data/Encoding/CP1258.o )
Loading package base ... linking ... done.
Loading package pretty- ... linking ... done.
Loading package array- ... linking ... done.
Loading package packedstring- ... linking ... done.
Loading package containers- ... linking ... done.
Loading package template-haskell ... linking ... done.
Loading package bytestring- ... linking ... done.
ghc-6.8.2: internal error: loadObj: can't map `dist/build/Data/Encoding/Helper/Template.o'
    (GHC version 6.8.2 for i386_unknown_linux)
    Please report this as a GHC bug:

Change History (4)

comment:1 Changed 8 years ago by ajd

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2225.

comment:2 Changed 8 years ago by igloo

  • Description modified (diff)
  • difficulty set to Unknown

comment:3 Changed 7 years ago by simonmar

  • Architecture changed from Unknown to Unknown/Multiple

comment:4 Changed 7 years ago by simonmar

  • Operating System changed from Unknown to Unknown/Multiple
Note: See TracTickets for help on using tickets.