Opened 6 years ago

Closed 5 years ago

#2218 closed bug (invalid)

ghci leaks memory on :reload etc

Reported by: ganesh Owned by:
Priority: normal Milestone: 6.10 branch
Component: GHCi Version: 6.8.2
Keywords: Cc: ganesh@…
Operating System: Linux Architecture: x86
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

Memory usage seems to increase on every :reload of interpreted code; I understand that the bytecode isn't being GCed. This is rather inconvenient for development on a memory constrained system.

Change History (5)

comment:1 Changed 6 years ago by guest

comment:2 Changed 6 years ago by simonmar

  • Difficulty set to Unknown

Object code is not GC'd, but byte-code certainly should be. It's not impossible we have a space leak though.

comment:3 Changed 6 years ago by ganesh

OK, since the behaviour I described isn't known I'll provide proper reproduction instructions.

comment:4 Changed 6 years ago by igloo

  • Milestone set to 6.10 branch

comment:5 Changed 5 years ago by igloo

  • Resolution set to invalid
  • Status changed from new to closed

No response, so closing.

Note: See TracTickets for help on using tickets.