Opened 6 years ago

Closed 6 years ago

#2198 closed bug (fixed)

Build failure on Mac OS X Tiger Intel

Reported by: guest Owned by:
Priority: normal Milestone: 6.8.3
Component: Build System Version: 6.8.2
Keywords: Cc:
Operating System: MacOS X Architecture: x86
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description (last modified by igloo)

The ghc in Macports fails to build on my Intel MacBook, running Mac OS 10.5.2. Here's what Gregory Wright, the ghc macports maintainer had to say:

It is possible that this is yet another file locking bug, which seem especially
easy to trigger when running OS X on faster hardware. The warning from
PackageConfig.hs may be spurious, the result of the import from InstalledPackageInfo.hi
silently failing. There are a few places where important error messages
are discarded, on the assumption that the cause of the failure will be obvious.

I've attached the build log. I'd be happy to provide more information, if it might help.

Wouter Swierstra

Attachments (1)

dest.log.zip (121.3 KB) - added by guest 6 years ago.
Log of ghc's build

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by guest

Log of ghc's build

comment:1 Changed 6 years ago by igloo

  • Description modified (diff)
  • Difficulty set to Unknown

comment:2 Changed 6 years ago by igloo

  • Milestone set to 6.8.3

comment:3 Changed 6 years ago by igloo

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the report. Happily, from http://www.haskell.org/pipermail/glasgow-haskell-users/2008-April/014661.html it sounds like this bug has already been fixed by

[pass -no-user-package-conf to ghc-inplace
Simon Marlow <simonmar@microsoft.com>**20080104162840] {
Note: See TracTickets for help on using tickets.