Opened 3 months ago

Closed 2 months ago

#15667 closed bug (fixed)

Readonly permissions bits are wrong

Reported by: Phyx- Owned by:
Priority: high Milestone: 8.6.2
Component: Compiler Version: 8.4.3
Keywords: Cc:
Operating System: Windows Architecture: Unknown/Multiple
Type of failure: GHC doesn't work at all Test Case:
Blocked By: Blocking:
Related Tickets: Differential Rev(s):
Wiki Page:

Description

Unfortunately it seems the mapping for the permission bits for GHC 8.6.1 seem to have gotten screwed up.

When installed to a read-only location GHC is no longer working due to it attempting to get write access as well.

Change History (4)

comment:1 Changed 2 months ago by Krzysztof Gogolewski <krz.gogolewski@…>

In deceb21/ghc:

Drop accidental write-attributes request

Summary:
The new filesystem code accidentally asks for write attributes
permissions when doing read-only access.

I believe this is what's causing the GHC 8.6.1 tarballs to fail
when installed to a privileged location.
I haven't been able to reproduce the issue yet, but this permission
bit is wrong anyway.

Test Plan: I'm still trying to workout how to test that this works,
changing the permissions on the folder doesn't seem to reproduce
the error on a tarball I made from before the change.

Reviewers: bgamari, tdammers

Reviewed By: bgamari

Subscribers: tdammers, monoidal, rwbarton, carter

GHC Trac Issues: #15667

Differential Revision: https://phabricator.haskell.org/D5177

comment:2 Changed 2 months ago by monoidal

Status: newmerge

comment:3 Changed 2 months ago by RyanGlScott

Milestone: 8.6.18.6.2

Moving to the 8.6.2 milestone, since these tickets were all recently marked as merge.

comment:4 Changed 2 months ago by bgamari

Resolution: fixed
Status: mergeclosed
Note: See TracTickets for help on using tickets.