Opened 8 days ago

Closed 5 hours ago

#14555 closed bug (fixed)

GHC Panic with TypeInType / levity polymorphism

Reported by: Iceland_jack Owned by:
Priority: normal Milestone:
Component: Compiler Version: 8.3
Keywords: LevityPolymorphism, TypeInType Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: None/Unknown Test Case: polykinds/T14555
Blocked By: Blocking:
Related Tickets: #14563 Differential Rev(s):
Wiki Page:

Description

{-# Language TypeInType #-}
{-# Language TypeOperators, DataKinds, PolyKinds #-}

import Data.Kind
import GHC.Types (TYPE)

data Exp :: [TYPE rep] -> TYPE rep -> Type where
  Lam :: Exp (a:xs) b -> Exp xs (a -> b)

gives

$ ghci -ignore-dot-ghci hs/126-bug.hs
GHCi, version 8.3.20171122: http://www.haskell.org/ghc/  :? for help
[1 of 1] Compiling Main             ( hs/126-bug.hs, interpreted )
ghc-stage2: panic! (the 'impossible' happened)
  (GHC version 8.3.20171122 for x86_64-unknown-linux):
	zonkTcTyVarToVar
  'LiftedRep
  Call stack:
      CallStack (from HasCallStack):
        callStackDoc, called at compiler/utils/Outputable.hs:1147:37 in ghc:Outputable
        pprPanic, called at compiler/typecheck/TcType.hs:1640:17 in ghc:TcType

Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug

caused by TypeInType. Removing the first line, we get an error

GHCi, version 8.3.20171122: http://www.haskell.org/ghc/  :? for help
[1 of 1] Compiling Main             ( hs/126-bug.hs, interpreted )

hs/126-bug.hs:7:19: error:
    • Expected kind ‘GHC.Types.RuntimeRep’, but ‘rep’ has kind ‘*’
    • In the first argument of ‘TYPE’, namely ‘rep’
      In the kind ‘[TYPE rep] -> TYPE rep -> Type’
  |
7 | data Exp :: [TYPE rep] -> TYPE rep -> Type where
  |                   ^^^

hs/126-bug.hs:7:32: error:
    • Expected kind ‘GHC.Types.RuntimeRep’, but ‘rep’ has kind ‘*’
    • In the first argument of ‘TYPE’, namely ‘rep’
      In the kind ‘[TYPE rep] -> TYPE rep -> Type’
  |
7 | data Exp :: [TYPE rep] -> TYPE rep -> Type where
  |                                ^^^
Failed, no modules loaded.
Prelude> 

Change History (4)

comment:1 Changed 8 days ago by Iceland_jack

Simpler example

data Exp :: TYPE rep -> Type where
  Lam :: Exp (a -> b)

can be fixed by explicitly quantifying over rep

data Exp :: forall rep. TYPE rep -> Type where -- ...
--
data Exp :: forall (rep::RuntimeRep). TYPE rep -> Type where -- ...

comment:2 Changed 5 days ago by Iceland_jack

comment:3 Changed 21 hours ago by Simon Peyton Jones <simonpj@…>

In 8361b2c5/ghc:

Fix SigTvs at the kind level

This patch fixes two bugs in the treatment of SigTvs at the
kind level:

- We should always generalise them, never default them
  (Trac #14555, #14563)

- We should check if they get unified with each other
  (Trac #11203)

Both are described in TcHsType
   Note [Kind generalisation and SigTvs]

comment:4 Changed 5 hours ago by simonpj

Resolution: fixed
Status: newclosed
Test Case: polykinds/T14555
Note: See TracTickets for help on using tickets.