Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#1390 closed bug (duplicate)

interpretBCO: unknown or unimplemented opcode 61764

Reported by: mail@… Owned by:
Priority: normal Milestone:
Component: Compiler Version: 6.6
Keywords: Cc:
Operating System: Unknown/Multiple Architecture: Unknown/Multiple
Type of failure: Difficulty: Unknown
Test Case: Blocked By:
Blocking: Related Tickets:

Description

I just hit an internal compiler error:

$ ghci blatt2a6.hs 
   ___         ___ _
  / _ \ /\  /\/ __(_)
 / /_\// /_/ / /  | |      GHC Interactive, version 6.6, for Haskell 98.
/ /_\\/ __  / /___| |      http://www.haskell.org/ghc/
\____/\/ /_/\____/|_|      Type :? for help.

Loading package base ... linking ... done.
[1 of 1] Compiling Main             ( blatt2a6.hs, interpreted )
Ok, modules loaded: Main.
*Main> pretty startn merk1
<interactive>: internal error: interpretBCO: unknown or unimplemented opcode 61764
    (GHC version 6.6 for i386_unknown_linux)
    Please report this as a GHC bug:  http://www.haskell.org/ghc/reportabug
Abgebrochen

Attachments (2)

blatt2a6.hs (1.2 KB) - added by mail@… 7 years ago.
Code that causes the error.
blatt2a6.2.hs (1.2 KB) - added by mail@… 7 years ago.
Very similar code that does not cause the problem.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by mail@…

Code that causes the error.

Changed 7 years ago by mail@…

Very similar code that does not cause the problem.

comment:1 Changed 7 years ago by thorkilnaur

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks a lot for this report. It seems that this is a duplicate of #1013, so I will close this ticket. For additional details, see http://www.haskell.org/pipermail/glasgow-haskell-bugs/2007-March/008800.html: The error is present in GHC 6.6, but should be fixed in GHC 6.6.1.

Best regards Thorkil

comment:2 Changed 6 years ago by simonmar

  • Architecture changed from Unknown to Unknown/Multiple

comment:3 Changed 6 years ago by simonmar

  • Operating System changed from Unknown to Unknown/Multiple
Note: See TracTickets for help on using tickets.